summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
commit1e60d28cc73a78604a94314d6bfbbc32e3d5fbbd (patch)
treeca8136a0afa54ff74d56a3c97d2a42e671627c44 /games-puzzle/greedy/greedy-0.2.0-r1.ebuild
parentgames-puzzle (diff)
downloadhistorical-1e60d28cc73a78604a94314d6bfbbc32e3d5fbbd.tar.gz
historical-1e60d28cc73a78604a94314d6bfbbc32e3d5fbbd.tar.bz2
historical-1e60d28cc73a78604a94314d6bfbbc32e3d5fbbd.zip
games-puzzle !@
Diffstat (limited to 'games-puzzle/greedy/greedy-0.2.0-r1.ebuild')
-rw-r--r--games-puzzle/greedy/greedy-0.2.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-puzzle/greedy/greedy-0.2.0-r1.ebuild b/games-puzzle/greedy/greedy-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..92a249e0a7ab
--- /dev/null
+++ b/games-puzzle/greedy/greedy-0.2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/greedy/greedy-0.2.0-r1.ebuild,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+inherit games
+
+DESCRIPTION="fun little ncurses puzzle game"
+HOMEPAGE="http://www.kotinet.com/juhamattin/linux/index.html"
+SRC_URI="http://www.kotinet.com/juhamattin/linux/download/${P}.tar.gz"
+
+KEYWORDS="x86 ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ sys-libs/ncurses"
+
+src_compile() {
+ emake FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # It wants a scores file. We need to touch one and install it.
+ touch greedy.scores
+ insinto ${GAMES_STATEDIR}
+ doins greedy.scores || die "doins failed"
+
+ dogamesbin greedy || die "dogamesbin failed"
+ dodoc CHANGES README TODO || die "dodoc failed"
+
+ prepgamesdirs
+ # We need to set the permissions correctly
+ chmod 664 ${D}/${GAMES_STATEDIR}/greedy.scores || die "chmod failed"
+}