summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2004-11-05 05:09:15 +0000
committerJoseph Jezak <josejx@gentoo.org>2004-11-05 05:09:15 +0000
commit6ae82ede1d8e9cc2e4a88578dc7aca90d973c761 (patch)
tree6e152036e9ef9a37ef58a9e69733fe4d2cb553ce /games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
parentgcc-getCC -> tc-getCC (diff)
downloadhistorical-6ae82ede1d8e9cc2e4a88578dc7aca90d973c761.tar.gz
historical-6ae82ede1d8e9cc2e4a88578dc7aca90d973c761.tar.bz2
historical-6ae82ede1d8e9cc2e4a88578dc7aca90d973c761.zip
Added ~ppc and gcc 3.4 fixes.
Diffstat (limited to 'games-puzzle/magiccube4d/magiccube4d-2.2.ebuild')
-rw-r--r--games-puzzle/magiccube4d/magiccube4d-2.2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild b/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
index 610267b835bb..7bf673a4a625 100644
--- a/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
+++ b/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild,v 1.4 2004/06/24 23:07:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/magiccube4d/magiccube4d-2.2.ebuild,v 1.5 2004/11/05 05:09:15 josejx Exp $
-inherit games
+inherit eutils games
MY_PV=${PV/./_}
DESCRIPTION="four-dimensional analog of Rubik's cube"
@@ -11,13 +11,19 @@ SRC_URI="http://www.superliminal.com/cube/mc4d-src-${MY_PV}.tgz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~ppc"
IUSE=""
DEPEND="virtual/x11"
S="${WORKDIR}/${PN}-src-${MY_PV}"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-EventHandler.patch
+}
+
src_compile() {
egamesconf || die
emake DFLAGS="${CFLAGS}" || die "emake failed"