summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2012-06-24 13:11:45 +0000
committerRichard Freeman <rich0@gentoo.org>2012-06-24 13:11:45 +0000
commit6158603c417a4ae9f15520ed8d005e619094df8f (patch)
tree6818d1f5b8454b627d49bd9ca204e06e0b8994f6 /games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild
parentUpdate CPAN upstream info (diff)
downloadhistorical-6158603c417a4ae9f15520ed8d005e619094df8f.tar.gz
historical-6158603c417a4ae9f15520ed8d005e619094df8f.tar.bz2
historical-6158603c417a4ae9f15520ed8d005e619094df8f.zip
Fixes for gnome icon cache - thanks hasufell.
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild')
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild b/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild
index 574a6d2a1630..32997eef0e83 100644
--- a/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild
+++ b/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild,v 1.2 2012/06/24 11:58:25 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/eternal-lands/eternal-lands-1.9.3-r1.ebuild,v 1.3 2012/06/24 13:11:45 rich0 Exp $
EAPI=2
-inherit eutils flag-o-matic games
+inherit eutils flag-o-matic gnome2-utils games
DESCRIPTION="An online MMORPG written in C and SDL"
HOMEPAGE="http://www.eternal-lands.com"
@@ -118,7 +118,7 @@ src_compile() {
}
src_install() {
- newicon "${DISTDIR}/eternal-lands.png" ${PN}.png
+ newicon -s 64 "${DISTDIR}/eternal-lands.png" ${PN}.png
newgamesbin el.x86.linux.bin el \
|| die "newgamesbin failed"
@@ -137,8 +137,14 @@ src_install() {
prepgamesdirs
}
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
games_pkg_postinst
+ gnome2_icon_cache_update
elog "Auto Update is now enabled in Eternal Lands"
elog "If an update occurs then the client will suddenly exit"
elog "Updates only happen when the game first loads"
@@ -150,5 +156,8 @@ pkg_postinst() {
# Make sure new files stay in games group
find "${ROOT}/${GAMES_DATADIR}/${PN}" -type d -exec chmod g+sx {} \;
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
}