summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-22 04:20:46 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-22 04:20:46 +0000
commitac1dba5abf3c7c99ea39e3872c19abc3241c4123 (patch)
tree97e1df59204dd36471d765bf40dc0ee311f0e666 /games-util
parentadd support for USE=doc #99858 (diff)
downloadhistorical-ac1dba5abf3c7c99ea39e3872c19abc3241c4123.tar.gz
historical-ac1dba5abf3c7c99ea39e3872c19abc3241c4123.tar.bz2
historical-ac1dba5abf3c7c99ea39e3872c19abc3241c4123.zip
initial import #76501 by gentoo_lan
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'games-util')
-rw-r--r--games-util/gamepick/ChangeLog8
-rw-r--r--games-util/gamepick/Manifest15
-rw-r--r--games-util/gamepick/files/digest-gamepick-0.301
-rw-r--r--games-util/gamepick/files/gamepick-0.30-paths.patch26
-rw-r--r--games-util/gamepick/gamepick-0.30.ebuild40
-rw-r--r--games-util/gamepick/metadata.xml5
6 files changed, 95 insertions, 0 deletions
diff --git a/games-util/gamepick/ChangeLog b/games-util/gamepick/ChangeLog
new file mode 100644
index 000000000000..1f0a54d0c531
--- /dev/null
+++ b/games-util/gamepick/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-util/gamepick
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gamepick/ChangeLog,v 1.1 2005/07/22 04:20:46 vapier Exp $
+
+*gamepick-0.30 (22 Jul 2005)
+
+ 22 Jul 2005; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by gentoo_lan #76501.
diff --git a/games-util/gamepick/Manifest b/games-util/gamepick/Manifest
new file mode 100644
index 000000000000..ffbd60290aa8
--- /dev/null
+++ b/games-util/gamepick/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 7bd2a50a3364c7764ca8aba2b6880de5 ChangeLog 351
+MD5 8414e45619aeb0d062a904ed31cbd90e gamepick-0.30.ebuild 1074
+MD5 86bcdc14d7b121d7104e62e56b976113 files/gamepick-0.30-paths.patch 765
+MD5 59ba428bb01df2957f9e905fc90ccb3a files/digest-gamepick-0.30 64
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC4HQugIKl8Uu19MoRAqkeAJsH3A+lDQgb+ag8xtqJbTdMBAlOIACfR8dZ
+SsImlCMxpShE17EGa4okLso=
+=p4Et
+-----END PGP SIGNATURE-----
diff --git a/games-util/gamepick/files/digest-gamepick-0.30 b/games-util/gamepick/files/digest-gamepick-0.30
new file mode 100644
index 000000000000..ce922af14e6e
--- /dev/null
+++ b/games-util/gamepick/files/digest-gamepick-0.30
@@ -0,0 +1 @@
+MD5 2da7a4b1c2e1240997367646439e9cd6 gamepick-0.30.tar.gz 40408
diff --git a/games-util/gamepick/files/gamepick-0.30-paths.patch b/games-util/gamepick/files/gamepick-0.30-paths.patch
new file mode 100644
index 000000000000..e2c686a8d4be
--- /dev/null
+++ b/games-util/gamepick/files/gamepick-0.30-paths.patch
@@ -0,0 +1,26 @@
+--- load_lists.c
++++ load_lists.c
+@@ -50,7 +50,7 @@
+ }
+ }
+
+- g_string_assign (info->conf_file, "gamepick.conf");
++ g_string_assign (info->conf_file, "CONFDIR/gamepick.conf");
+ if (file_readable (info->conf_file->str))
+ return NULL;
+
+--- gamepick.h
++++ gamepick.h
+@@ -6,9 +6,9 @@
+
+ /* configure these to your own systems */
+ /* or overide them with -c <conf file> */
+-static const gchar default_cmd_dir[] = ".";
+-static const gchar default_icon_dir[] = ".";
+-static const gchar default_stage2[] = "./gamepick-stage2";
++static const gchar default_cmd_dir[] = "GAMES_BINDIR";
++static const gchar default_icon_dir[] = "GAMES_DATADIR";
++static const gchar default_stage2[] = "GAMES_BINDIR/gamepick-stage2";
+
+ enum browse_targets {bt_cmd, bt_icon};
+
diff --git a/games-util/gamepick/gamepick-0.30.ebuild b/games-util/gamepick/gamepick-0.30.ebuild
new file mode 100644
index 000000000000..44514dc46f26
--- /dev/null
+++ b/games-util/gamepick/gamepick-0.30.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gamepick/gamepick-0.30.ebuild,v 1.1 2005/07/22 04:20:46 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Launch opengl games with custom graphic settings"
+HOMEPAGE="http://www.rillion.net/gamepick/index.html"
+SRC_URI="http://www.rillion.net/gamepick/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk2"
+
+DEPEND="=x11-libs/gtk+-2*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-paths.patch
+ sed -i \
+ -e "s:GAMES_CONFDIR:${GAMES_SYSCONFDIR}:" \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ load_lists.c gamepick.h
+ sed -i \
+ -e "/^flags/s:-Wall -Werror -pedantic -c -g:-c ${CFLAGS}:" \
+ Makefile
+}
+
+src_install() {
+ dogamesbin gamepick gamepick-stage{2,3} || die "dogamesbin"
+ dodoc ABOUT INSTALL README TODO
+ insinto "${GAMES_SYSCONFDIR}"
+ doins gamepick.conf
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.png *.xpm *.gif
+ prepgamesdirs
+}
diff --git a/games-util/gamepick/metadata.xml b/games-util/gamepick/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/gamepick/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>