summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2002-08-06 04:42:12 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2002-08-06 04:42:12 +0000
commitad356355732cee12090a0fbc4cc80da708b66461 (patch)
treef6363c194604efa067971c1e1957fb44388f782b /gnome-base/gconf
parentNew version (diff)
downloadhistorical-ad356355732cee12090a0fbc4cc80da708b66461.tar.gz
historical-ad356355732cee12090a0fbc4cc80da708b66461.tar.bz2
historical-ad356355732cee12090a0fbc4cc80da708b66461.zip
Fix bug #5797
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog7
-rw-r--r--gnome-base/gconf/files/digest-gconf-1.2.0-r51
-rw-r--r--gnome-base/gconf/gconf-1.2.0-r5.ebuild80
3 files changed, 87 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 9c7ab0ad2bb4..98465ad9ce02 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.20 2002/08/05 20:46:08 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.21 2002/08/06 04:42:12 leonardop Exp $
+*gconf-1.2.0-r5 (05 Aug 2002)
+ 05 Aug 2002; Leonardo Boshell <leonardop@gentoo.org> gconf-1.2.0-r5.ebuild:
+ Fix sandbox violations affecting the installation under certain
+ circumstances. Closes bug #5797.
+
*gconf-1.2.1 (05 Aug 2002)
05 Aug 2002 ; Spider <spider@gentoo.org> gconf-1.2.1.ebuild :
new version, updated deps
diff --git a/gnome-base/gconf/files/digest-gconf-1.2.0-r5 b/gnome-base/gconf/files/digest-gconf-1.2.0-r5
new file mode 100644
index 000000000000..04dc91a16097
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-1.2.0-r5
@@ -0,0 +1 @@
+MD5 9815ca4ee765e86047d0f096baf8783b GConf-1.2.0.tar.bz2 935782
diff --git a/gnome-base/gconf/gconf-1.2.0-r5.ebuild b/gnome-base/gconf/gconf-1.2.0-r5.ebuild
new file mode 100644
index 000000000000..470ad701f8bf
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.2.0-r5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.2.0-r5.ebuild,v 1.1 2002/08/06 04:42:12 leonardop Exp $
+
+inherit gnome2
+
+MY_PN=GConf
+S=${WORKDIR}/${MY_PN}-${PV}
+DESCRIPTION="Gnome Configuration System and Daemon"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${MY_PN}-${PV}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="x86 ppc"
+
+RDEPEND=">=dev-libs/glib-2.0.1
+ >=gnome-base/ORBit2-2.4.0
+ >=dev-libs/libxml2-2.4.17
+ >=net-libs/linc-0.5.0
+ >=x11-libs/gtk+-2.0.5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( dev-util/gtk-doc )"
+
+LIBTOOL_FIX="1"
+
+# This should fix weird sandbox violations when we call `kill_gconf' and
+# directories like /etc/gconf/gconf.xml.mandatory and /root/.gconfd are
+# not present
+addwrite "/etc/gconf:/root"
+
+kill_gconf () {
+ # this function will kill all running gconfd that could be causing troubles
+ if [ -x /usr/bin/gconftool ]
+ then
+ /usr/bin/gconftool --shutdown
+ fi
+ if [ -x /usr/bin/gconftool-1 ]
+ then
+ /usr/bin/gconftool-1 --shutdown
+ fi
+
+ # and for gconf 2
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+}
+
+pkg_setup () {
+ kill_gconf
+}
+pkg_preinst () {
+ kill_gconf
+ # hack hack
+ dodir /etc/gconf/gconf.xml.mandatory
+ dodir /etc/gconf/gconf.xml.defaults
+ touch ${D}/etc/gconf/gconf.xml.mandatory/.keep
+ touch ${D}/etc/gconf/gconf.xml.defaults/.keep
+
+ dodir /etc/env.d
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' >${D}/etc/env.d/50gconf
+
+ dodir /root/.gconfd
+
+}
+pkg_postinst () {
+ kill_gconf
+ gnome2_pkg_postinst
+
+ #change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+
+}
+
+DOCS="ABOUT-NLS AUTHORS ChangeLog COPYING README* INSTALL NEWS TODO"