summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-10-05 16:27:18 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-10-05 16:27:18 +0000
commitc069eb3e83355aa290c7c8388d023b2ace36ffcd (patch)
treec3d8c58ee417c844b6394337d94034548810d6e9 /gnustep-apps
parentbump 2.16-r2 on mips (diff)
downloadhistorical-c069eb3e83355aa290c7c8388d023b2ace36ffcd.tar.gz
historical-c069eb3e83355aa290c7c8388d023b2ace36ffcd.tar.bz2
historical-c069eb3e83355aa290c7c8388d023b2ace36ffcd.zip
Broke apart some optional components from gworkspace; added gnustep-apps/desktop gnustep-apps/recycler; gnustep-apps/gwnet
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/desktop/ChangeLog10
-rw-r--r--gnustep-apps/desktop/Manifest3
-rw-r--r--gnustep-apps/desktop/desktop-0.7_pre20040928.ebuild36
-rw-r--r--gnustep-apps/desktop/files/digest-desktop-0.7_pre200409280
-rw-r--r--gnustep-apps/desktop/files/seperate-build.patch80
-rw-r--r--gnustep-apps/desktop/metadata.xml8
-rw-r--r--gnustep-apps/gwnet/ChangeLog10
-rw-r--r--gnustep-apps/gwnet/Manifest2
-rw-r--r--gnustep-apps/gwnet/files/digest-gwnet-0.1_pre200409280
-rw-r--r--gnustep-apps/gwnet/gwnet-0.1_pre20040928.ebuild30
-rw-r--r--gnustep-apps/gwnet/metadata.xml10
-rw-r--r--gnustep-apps/gworkspace/ChangeLog11
-rw-r--r--gnustep-apps/gworkspace/Manifest2
-rw-r--r--gnustep-apps/gworkspace/files/digest-gworkspace-0.6.6_pre200409081
-rw-r--r--gnustep-apps/gworkspace/files/digest-gworkspace-0.6.6_pre20040928-r20
-rw-r--r--gnustep-apps/gworkspace/files/seperate-desktop-recycler.patch11
-rw-r--r--gnustep-apps/gworkspace/gworkspace-0.6.6_pre20040928-r2.ebuild (renamed from gnustep-apps/gworkspace/gworkspace-0.6.6_pre20040908.ebuild)18
-rw-r--r--gnustep-apps/recycler/ChangeLog10
-rw-r--r--gnustep-apps/recycler/Manifest3
-rw-r--r--gnustep-apps/recycler/files/digest-recycler-0.7_pre200409280
-rw-r--r--gnustep-apps/recycler/files/seperate-build.patch56
-rw-r--r--gnustep-apps/recycler/metadata.xml8
-rw-r--r--gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild35
23 files changed, 338 insertions, 6 deletions
diff --git a/gnustep-apps/desktop/ChangeLog b/gnustep-apps/desktop/ChangeLog
new file mode 100644
index 000000000000..5d1a55507922
--- /dev/null
+++ b/gnustep-apps/desktop/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnustep-apps/desktop
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/desktop/ChangeLog,v 1.1 2004/10/05 16:27:00 fafhrd Exp $
+
+*desktop-0.7_pre20040928 (05 Oct 2004)
+
+ 05 Oct 2004; Armando Di Cianno <fafhrd@gentoo.org> +metadata.xml,
+ +files/seperate-build.patch, +desktop-0.7_pre20040928.ebuild:
+ Original package import.
+
diff --git a/gnustep-apps/desktop/Manifest b/gnustep-apps/desktop/Manifest
new file mode 100644
index 000000000000..725f839f3943
--- /dev/null
+++ b/gnustep-apps/desktop/Manifest
@@ -0,0 +1,3 @@
+MD5 064f5a3758319b172a4f18e59ec2ee2e desktop-0.7_pre20040928.ebuild 654
+MD5 ebbafd529d14e3d9a0fe33fd0cb7202f metadata.xml 228
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-desktop-0.7_pre20040928 0
diff --git a/gnustep-apps/desktop/desktop-0.7_pre20040928.ebuild b/gnustep-apps/desktop/desktop-0.7_pre20040928.ebuild
new file mode 100644
index 000000000000..d870b68aff95
--- /dev/null
+++ b/gnustep-apps/desktop/desktop-0.7_pre20040928.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/desktop/desktop-0.7_pre20040928.ebuild,v 1.1 2004/10/05 16:27:00 fafhrd Exp $
+
+ECVS_CVS_COMMAND="cvs -q"
+ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
+ECVS_USER="anoncvs"
+ECVS_AUTH="ext"
+ECVS_MODULE="gnustep/usr-apps/gworkspace/${PN/d/D}"
+ECVS_CO_OPTS="-D ${PV/*_pre}"
+ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
+inherit gnustep cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+DESCRIPTION="A desktop manager for GNUstep."
+HOMEPAGE="http://www.gnustep.it/enrico/gworkspace/"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="${IUSE}"
+DEPEND="${GS_DEPEND}
+ gnustep-apps/gworkspace"
+RDEPEND="${GS_RDEPEND}
+ gnustep-apps/gworkspace
+ gnustep-apps/recycler"
+
+src_compile() {
+ egnustep_env
+ EPATCH_OPTIONS="-d ${S}" epatch ${FILESDIR}/seperate-build.patch
+ egnustep_make
+}
+
diff --git a/gnustep-apps/desktop/files/digest-desktop-0.7_pre20040928 b/gnustep-apps/desktop/files/digest-desktop-0.7_pre20040928
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/gnustep-apps/desktop/files/digest-desktop-0.7_pre20040928
diff --git a/gnustep-apps/desktop/files/seperate-build.patch b/gnustep-apps/desktop/files/seperate-build.patch
new file mode 100644
index 000000000000..3417cf5e0cce
--- /dev/null
+++ b/gnustep-apps/desktop/files/seperate-build.patch
@@ -0,0 +1,80 @@
+diff -ur Desktop.old/Desktop.m Desktop/Desktop.m
+--- Desktop.old/Desktop.m 2004-09-24 07:34:47.000000000 -0400
++++ Desktop/Desktop.m 2004-10-05 11:46:03.407363952 -0400
+@@ -30,9 +30,9 @@
+ #include "Dock.h"
+ #include "Preferences/DesktopPrefs.h"
+ #include "Dialogs/StartAppWin.h"
+-#include "FSNode.h"
+-#include "FSNodeRep.h"
+-#include "FSNFunctions.h"
++#include "FSNode/FSNode.h"
++#include "FSNode/FSNodeRep.h"
++#include "FSNode/FSNFunctions.h"
+
+ #define CHECKSIZE(sz) \
+ if (sz.width < 0) sz.width = 0; \
+diff -ur Desktop.old/DesktopView.h Desktop/DesktopView.h
+--- Desktop.old/DesktopView.h 2004-09-02 07:31:38.000000000 -0400
++++ Desktop/DesktopView.h 2004-10-05 11:45:08.133766816 -0400
+@@ -25,7 +25,7 @@
+ #ifndef DESKTOP_VIEW_H
+ #define DESKTOP_VIEW_H
+
+-#include "FSNIconsView.h"
++#include "FSNode/FSNIconsView.h"
+
+ @class NSImage;
+ @class Desktop;
+diff -ur Desktop.old/DesktopView.m Desktop/DesktopView.m
+--- Desktop.old/DesktopView.m 2004-09-21 20:00:25.000000000 -0400
++++ Desktop/DesktopView.m 2004-10-05 11:46:54.995521360 -0400
+@@ -26,9 +26,9 @@
+ #include <AppKit/AppKit.h>
+ #include <GNUstepGUI/GSDisplayServer.h>
+ #include <math.h>
+-#include "FSNodeRep.h"
+-#include "FSNIcon.h"
+-#include "FSNFunctions.h"
++#include "FSNode/FSNodeRep.h"
++#include "FSNode/FSNIcon.h"
++#include "FSNode/FSNFunctions.h"
+ #include "DesktopView.h"
+ #include "Desktop.h"
+ #include "Dock.h"
+diff -ur Desktop.old/Dialogs/StartAppWin.m Desktop/Dialogs/StartAppWin.m
+--- Desktop.old/Dialogs/StartAppWin.m 2004-05-11 08:31:37.000000000 -0400
++++ Desktop/Dialogs/StartAppWin.m 2004-10-05 11:48:23.311095352 -0400
+@@ -25,7 +25,7 @@
+ #include <Foundation/Foundation.h>
+ #include <AppKit/AppKit.h>
+ #include "StartAppWin.h"
+-#include "GNUstep.h"
++//#include "GNUstep.h"
+
+ static NSString *nibName = @"StartAppWin";
+
+diff -ur Desktop.old/Dock/Dock.h Desktop/Dock/Dock.h
+--- Desktop.old/Dock/Dock.h 2004-09-02 07:31:38.000000000 -0400
++++ Desktop/Dock/Dock.h 2004-10-05 11:45:44.758199056 -0400
+@@ -27,7 +27,7 @@
+
+ #include <AppKit/NSView.h>
+ #include "Desktop.h"
+-#include "FSNodeRep.h"
++#include "FSNode/FSNodeRep.h"
+
+ @class NSWindow;
+ @class NSColor;
+diff -ur Desktop.old/Dock/DockIcon.h Desktop/Dock/DockIcon.h
+--- Desktop.old/Dock/DockIcon.h 2004-06-27 07:30:51.000000000 -0400
++++ Desktop/Dock/DockIcon.h 2004-10-05 11:47:10.600149096 -0400
+@@ -26,7 +26,7 @@
+ #define DOCK_ICON_H
+
+ #include <AppKit/NSView.h>
+-#include "FSNIcon.h"
++#include "FSNode/FSNIcon.h"
+
+ @class NSColor;
+ @class NSImage;
diff --git a/gnustep-apps/desktop/metadata.xml b/gnustep-apps/desktop/metadata.xml
new file mode 100644
index 000000000000..3caa02b8c415
--- /dev/null
+++ b/gnustep-apps/desktop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+A desktop manager for GNUstep.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/gwnet/ChangeLog b/gnustep-apps/gwnet/ChangeLog
new file mode 100644
index 000000000000..2210f3804e8f
--- /dev/null
+++ b/gnustep-apps/gwnet/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnustep-apps/gwnet
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gwnet/ChangeLog,v 1.1 2004/10/05 16:27:18 fafhrd Exp $
+
+*gwnet-0.1_pre20040928 (05 Oct 2004)
+
+ 05 Oct 2004; Armando Di Cianno <fafhrd@gentoo.org> +metadata.xml,
+ +gwnet-0.1_pre20040928.ebuild:
+ Original package added; keyworded for ~x86
+
diff --git a/gnustep-apps/gwnet/Manifest b/gnustep-apps/gwnet/Manifest
new file mode 100644
index 000000000000..c957d0416561
--- /dev/null
+++ b/gnustep-apps/gwnet/Manifest
@@ -0,0 +1,2 @@
+MD5 bc2dca66386ca7d73568ba9b8a10289d gwnet-0.1_pre20040928.ebuild 676
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gwnet-0.1_pre20040928 0
diff --git a/gnustep-apps/gwnet/files/digest-gwnet-0.1_pre20040928 b/gnustep-apps/gwnet/files/digest-gwnet-0.1_pre20040928
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/gnustep-apps/gwnet/files/digest-gwnet-0.1_pre20040928
diff --git a/gnustep-apps/gwnet/gwnet-0.1_pre20040928.ebuild b/gnustep-apps/gwnet/gwnet-0.1_pre20040928.ebuild
new file mode 100644
index 000000000000..1dca636612e3
--- /dev/null
+++ b/gnustep-apps/gwnet/gwnet-0.1_pre20040928.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gwnet/gwnet-0.1_pre20040928.ebuild,v 1.1 2004/10/05 16:27:18 fafhrd Exp $
+
+ECVS_CVS_COMMAND="cvs -q"
+ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
+ECVS_USER="anoncvs"
+ECVS_AUTH="ext"
+ECVS_MODULE="gnustep/usr-apps/gworkspace/${PN/gwn/GWN}"
+ECVS_CO_OPTS="-D ${PV/*_pre}"
+ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
+inherit gnustep cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+DESCRIPTION="A GNUstep network filesystem file browser."
+HOMEPAGE="http://www.gnustep.it/enrico/gworkspace/"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="${IUSE}"
+# Yes, currently this app does not optional depend on smb, it requires it
+DEPEND="${GS_DEPEND}
+ gnustep-libs/smbkit"
+RDEPEND="${GS_RDEPEND}
+ gnustep-libs/smbkit"
+
diff --git a/gnustep-apps/gwnet/metadata.xml b/gnustep-apps/gwnet/metadata.xml
new file mode 100644
index 000000000000..325a868e8c3d
--- /dev/null
+++ b/gnustep-apps/gwnet/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+GNUstep network filesystem file browser.
+
+Great for FTP, and optionally, SMB shares.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/gworkspace/ChangeLog b/gnustep-apps/gworkspace/ChangeLog
index ad6d71799526..2715ccfa7b88 100644
--- a/gnustep-apps/gworkspace/ChangeLog
+++ b/gnustep-apps/gworkspace/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnustep-apps/gworkspace
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gworkspace/ChangeLog,v 1.6 2004/10/04 23:56:22 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gworkspace/ChangeLog,v 1.7 2004/10/05 16:26:19 fafhrd Exp $
+
+*gworkspace-0.6.6_pre20040928-r2 (05 Oct 2004)
+
+ 05 Oct 2004; Armando Di Cianno <fafhrd@gentoo.org>
+ +files/seperate-desktop-recycler.patch,
+ -gworkspace-0.6.6_pre20040908.ebuild,
+ +gworkspace-0.6.6_pre20040928-r2.ebuild:
+ Removed old package revision; removed desktop and recycler support (moved to
+ seperate packages)
*gworkspace-0.6.6_pre20040928-r1 (04 Oct 2004)
diff --git a/gnustep-apps/gworkspace/Manifest b/gnustep-apps/gworkspace/Manifest
index 636c7316ba0a..06e197a4f89e 100644
--- a/gnustep-apps/gworkspace/Manifest
+++ b/gnustep-apps/gworkspace/Manifest
@@ -1,3 +1,4 @@
+MD5 97975e78a20e45d62cb176c1153313d7 gworkspace-0.6.6_pre20040928-r2.ebuild 773
MD5 fc35533cd18704845b8a9528844d0cf4 gworkspace-0.5.3.ebuild 619
MD5 17550668a1428fcc2a0e7bc989ac3931 gworkspace-0.6.6_pre20040928-r1.ebuild 931
MD5 399f71cc47ffd1480fb919ba5f4aecf4 gworkspace-0.6.6_pre20040908.ebuild 652
@@ -8,3 +9,4 @@ MD5 61b8e5ab2a32b906a1376c1425c8471a files/digest-gworkspace-0.6.6_pre20040908 8
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gworkspace-0.6.6_pre20040928 0
MD5 48cb1091fdd1df58f0a32711945b64fb files/digest-gworkspace-0.5.3 69
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gworkspace-0.6.6_pre20040928-r1 0
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gworkspace-0.6.6_pre20040928-r2 0
diff --git a/gnustep-apps/gworkspace/files/digest-gworkspace-0.6.6_pre20040908 b/gnustep-apps/gworkspace/files/digest-gworkspace-0.6.6_pre20040908
deleted file mode 100644
index 80139d67b71a..000000000000
--- a/gnustep-apps/gworkspace/files/digest-gworkspace-0.6.6_pre20040908
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1f1f1b06b4c7b9ecafd294809b5e7e0d gworkspace-0.6.6_pre20040908.tar.gz 1537328
diff --git a/gnustep-apps/gworkspace/files/digest-gworkspace-0.6.6_pre20040928-r2 b/gnustep-apps/gworkspace/files/digest-gworkspace-0.6.6_pre20040928-r2
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/gnustep-apps/gworkspace/files/digest-gworkspace-0.6.6_pre20040928-r2
diff --git a/gnustep-apps/gworkspace/files/seperate-desktop-recycler.patch b/gnustep-apps/gworkspace/files/seperate-desktop-recycler.patch
new file mode 100644
index 000000000000..8ade945cf39c
--- /dev/null
+++ b/gnustep-apps/gworkspace/files/seperate-desktop-recycler.patch
@@ -0,0 +1,11 @@
+--- GNUmakefile.in 2004-10-05 11:21:56.029398848 -0400
++++ GNUmakefile.in 2004-10-05 11:22:16.076351248 -0400
+@@ -17,8 +17,6 @@
+ Inspector \
+ Operation \
+ Finder \
+- Desktop \
+- Recycler \
+ GWorkspace
+
+ -include GNUmakefile.preamble
diff --git a/gnustep-apps/gworkspace/gworkspace-0.6.6_pre20040908.ebuild b/gnustep-apps/gworkspace/gworkspace-0.6.6_pre20040928-r2.ebuild
index c69795b1f5c7..f6d3b4551d6e 100644
--- a/gnustep-apps/gworkspace/gworkspace-0.6.6_pre20040908.ebuild
+++ b/gnustep-apps/gworkspace/gworkspace-0.6.6_pre20040928-r2.ebuild
@@ -1,14 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gworkspace/gworkspace-0.6.6_pre20040908.ebuild,v 1.1 2004/09/24 01:06:48 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gworkspace/gworkspace-0.6.6_pre20040928-r2.ebuild,v 1.1 2004/10/05 16:26:19 fafhrd Exp $
-inherit gnustep
+ECVS_CVS_COMMAND="cvs -q"
+ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
+ECVS_USER="anoncvs"
+ECVS_AUTH="ext"
+ECVS_MODULE="gnustep/usr-apps/${PN}"
+ECVS_CO_OPTS="-D ${PV/*_pre}"
+ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
+inherit gnustep cvs
-S=${WORKDIR}/${PN}
+S=${WORKDIR}/${ECVS_MODULE}
DESCRIPTION="A workspace manager for GNUstep."
HOMEPAGE="http://www.gnustep.it/enrico/gworkspace/"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
+
KEYWORDS="~x86"
LICENSE="GPL-2"
SLOT="0"
@@ -21,6 +29,8 @@ RDEPEND="${GS_RDEPEND}"
src_compile() {
egnustep_env
+ EPATCH_OPTIONS="-d ${S}" epatch ${FILESDIR}/seperate-desktop-recycler.patch
+
econf || die "configure failed"
egnustep_make
diff --git a/gnustep-apps/recycler/ChangeLog b/gnustep-apps/recycler/ChangeLog
new file mode 100644
index 000000000000..2a4512ae01a1
--- /dev/null
+++ b/gnustep-apps/recycler/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnustep-apps/recycler
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/recycler/ChangeLog,v 1.1 2004/10/05 16:26:40 fafhrd Exp $
+
+*recycler-0.7_pre20040928 (05 Oct 2004)
+
+ 05 Oct 2004; Armando Di Cianno <fafhrd@gentoo.org> +metadata.xml,
+ +files/seperate-build.patch, +recycler-0.7_pre20040928.ebuild:
+ Original package import.
+
diff --git a/gnustep-apps/recycler/Manifest b/gnustep-apps/recycler/Manifest
new file mode 100644
index 000000000000..e9a4d079c91f
--- /dev/null
+++ b/gnustep-apps/recycler/Manifest
@@ -0,0 +1,3 @@
+MD5 ada18eaded6c6a9f71b2a0f0a5c743bd recycler-0.7_pre20040928.ebuild 811
+MD5 87d1c55f65942899d02fea4a72e0734b metadata.xml 221
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-recycler-0.7_pre20040928 0
diff --git a/gnustep-apps/recycler/files/digest-recycler-0.7_pre20040928 b/gnustep-apps/recycler/files/digest-recycler-0.7_pre20040928
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/gnustep-apps/recycler/files/digest-recycler-0.7_pre20040928
diff --git a/gnustep-apps/recycler/files/seperate-build.patch b/gnustep-apps/recycler/files/seperate-build.patch
new file mode 100644
index 000000000000..b1594509fdd8
--- /dev/null
+++ b/gnustep-apps/recycler/files/seperate-build.patch
@@ -0,0 +1,56 @@
+diff -ur Recycler.old/Recycler.m Recycler/Recycler.m
+--- Recycler.old/Recycler.m 2004-09-21 20:00:27.000000000 -0400
++++ Recycler/Recycler.m 2004-10-05 11:58:44.337684960 -0400
+@@ -28,10 +28,10 @@
+ #include "RecyclerView.h"
+ #include "Preferences/RecyclerPrefs.h"
+ #include "Dialogs/StartAppWin.h"
+-#include "FSNode.h"
+-#include "FSNodeRep.h"
+-#include "FSNFunctions.h"
+-#include "GNUstep.h"
++#include "FSNode/FSNode.h"
++#include "FSNode/FSNodeRep.h"
++#include "FSNode/FSNFunctions.h"
++//#include "GNUstep.h"
+
+
+ static Recycler *recycler = nil;
+diff -ur Recycler.old/RecyclerIcon.h Recycler/RecyclerIcon.h
+--- Recycler.old/RecyclerIcon.h 2004-06-15 06:20:26.000000000 -0400
++++ Recycler/RecyclerIcon.h 2004-10-05 11:58:59.077444176 -0400
+@@ -26,7 +26,7 @@
+ #define RECYCLER_ICON_H
+
+ #include <AppKit/NSView.h>
+-#include "FSNIcon.h"
++#include "FSNode/FSNIcon.h"
+
+ @class NSColor;
+ @class NSImage;
+diff -ur Recycler.old/RecyclerView.h Recycler/RecyclerView.h
+--- Recycler.old/RecyclerView.h 2004-09-02 07:31:38.000000000 -0400
++++ Recycler/RecyclerView.h 2004-10-05 11:58:15.332094480 -0400
+@@ -27,7 +27,7 @@
+
+ #include <AppKit/NSView.h>
+ #include "Recycler.h"
+-#include "FSNodeRep.h"
++#include "FSNode/FSNodeRep.h"
+
+ @class NSImage;
+ @class RecyclerIcon;
+diff -ur Recycler.old/RecyclerView.m Recycler/RecyclerView.m
+--- Recycler.old/RecyclerView.m 2004-09-21 20:00:27.000000000 -0400
++++ Recycler/RecyclerView.m 2004-10-05 11:59:18.241530792 -0400
+@@ -27,8 +27,8 @@
+ #include <math.h>
+ #include "RecyclerView.h"
+ #include "RecyclerIcon.h"
+-#include "FSNFunctions.h"
+-#include "GNUstep.h"
++#include "FSNode/FSNFunctions.h"
++//#include "GNUstep.h"
+
+ #define WIN_SIZE 64
+ #define ICN_SIZE 48
diff --git a/gnustep-apps/recycler/metadata.xml b/gnustep-apps/recycler/metadata.xml
new file mode 100644
index 000000000000..ef0d9002601e
--- /dev/null
+++ b/gnustep-apps/recycler/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+A recycler for GNUstep.
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild b/gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild
new file mode 100644
index 000000000000..976c80eac3de
--- /dev/null
+++ b/gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/recycler/recycler-0.7_pre20040928.ebuild,v 1.1 2004/10/05 16:26:40 fafhrd Exp $
+
+ECVS_CVS_COMMAND="cvs -q"
+ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
+ECVS_USER="anoncvs"
+ECVS_AUTH="ext"
+ECVS_MODULE="gnustep/usr-apps/gworkspace/${PN/r/R}"
+ECVS_CO_OPTS="-D ${PV/*_pre}"
+ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
+inherit gnustep cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+DESCRIPTION="A recycler for GNUstep."
+HOMEPAGE="http://www.gnustep.it/enrico/gworkspace/"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="${IUSE}"
+DEPEND="${GS_DEPEND}
+ gnustep-apps/gworkspace"
+RDEPEND="${GS_RDEPEND}
+ gnustep-apps/gworkspace"
+
+src_compile() {
+ egnustep_env
+ EPATCH_OPTIONS="-d ${S}" epatch ${FILESDIR}/seperate-build.patch
+ egnustep_make
+}
+