summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-02-06 07:49:01 +0000
committerDan Armak <danarmak@gentoo.org>2005-02-06 07:49:01 +0000
commitd39df8a2b0ba9e777f41ad61b7c49203679b419f (patch)
tree95a5cd4e98096aa43b98f602e21821d0dd4d8561 /kde-base/artsplugin-mpeglib
parentClean up ebuild and move manpages/patches to our mirrors. (diff)
downloadhistorical-d39df8a2b0ba9e777f41ad61b7c49203679b419f.tar.gz
historical-d39df8a2b0ba9e777f41ad61b7c49203679b419f.tar.bz2
historical-d39df8a2b0ba9e777f41ad61b7c49203679b419f.zip
add patch fixing typo in Makefile.am. I'm not sure the typo actually breaks anything, but it could... sumitted upstream as bugs.kde.org 98675.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'kde-base/artsplugin-mpeglib')
-rw-r--r--kde-base/artsplugin-mpeglib/Manifest3
-rw-r--r--kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild6
-rw-r--r--kde-base/artsplugin-mpeglib/files/artsc-typo.diff11
3 files changed, 17 insertions, 3 deletions
diff --git a/kde-base/artsplugin-mpeglib/Manifest b/kde-base/artsplugin-mpeglib/Manifest
index e63fc9fcc9df..93d7c83b969f 100644
--- a/kde-base/artsplugin-mpeglib/Manifest
+++ b/kde-base/artsplugin-mpeglib/Manifest
@@ -1,6 +1,7 @@
-MD5 fdf94fc55218fbc52720a3f22e4dfab7 artsplugin-mpeglib-3.4.0_beta2.ebuild 728
+MD5 6ee16c72e42f1b590377c56628c67ca3 artsplugin-mpeglib-3.4.0_beta2.ebuild 787
MD5 88afe203d3a6324fc83bbfaf1adb0785 artsplugin-mpeglib-3.4.0_beta1.ebuild 733
MD5 7b44223bcd7c60844b478f96b03f499c ChangeLog 779
MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
+MD5 02f0ce7ea2ec6f7f7042f7f40f7f7fe7 files/artsc-typo.diff 439
MD5 43e784a2028b42eff11cfacd5dc9e845 files/digest-artsplugin-mpeglib-3.4.0_beta1 231
MD5 c43e1f638e3c583d4d696aad7f994232 files/digest-artsplugin-mpeglib-3.4.0_beta2 314
diff --git a/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild b/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild
index 3cc9d37de8fe..f564c34b035c 100644
--- a/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild
+++ b/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild,v 1.1 2005/02/05 11:39:10 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild,v 1.2 2005/02/06 07:49:01 danarmak Exp $
KMNAME=kdemultimedia
KMMODULE=mpeglib_artsplug
@@ -16,9 +16,11 @@ OLDDEPEND="~kde-base/mpeglib-$PV"
KMCOPYLIB="libmpeg mpeglib/lib/"
KMEXTRACTONLY="mpeglib/"
+PATCHES="$FILESDIR/artsc-typo.diff" # bugs.kde.org 98675
+
pkg_setup() {
if ! useq arts; then
eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
die
fi
-} \ No newline at end of file
+}
diff --git a/kde-base/artsplugin-mpeglib/files/artsc-typo.diff b/kde-base/artsplugin-mpeglib/files/artsc-typo.diff
new file mode 100644
index 000000000000..f5bd037aeaaa
--- /dev/null
+++ b/kde-base/artsplugin-mpeglib/files/artsc-typo.diff
@@ -0,0 +1,11 @@
+--- mpeglib_artsplug/Makefile.am.orig 2005-02-04 00:48:27.000000000 +0200
++++ mpeglib_artsplug/Makefile.am 2005-02-06 09:27:29.095013192 +0200
+@@ -89,7 +89,7 @@
+
+ bin_PROGRAMS = mpeglibartsplay
+
+-mpeglibartsplay_LDFLAGS = $(ARTCS_LIBS) $(all_libraries)
++mpeglibartsplay_LDFLAGS = $(ARTSC_LIBS) $(all_libraries)
+ mpeglibartsplay_SOURCES = mpeglibartsplay.cpp
+
+ mpeglibartsplay_LDADD = -lsoundserver_idl \