summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 23:02:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 23:02:08 +0000
commit4de417b1bb3bc2e9455805558437ef13d2cf9344 (patch)
tree870de20bd2e0eebb646138c5b5ac72aca4b40b3a /kde-base/kalzium
parentVersion bump. (diff)
downloadhistorical-4de417b1bb3bc2e9455805558437ef13d2cf9344.tar.gz
historical-4de417b1bb3bc2e9455805558437ef13d2cf9344.tar.bz2
historical-4de417b1bb3bc2e9455805558437ef13d2cf9344.zip
Bump KDE 4.2.1
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.2.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index b864d560c0c6..074849a6a02d 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.111 2009/02/22 22:17:03 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.112 2009/03/04 20:28:01 alexxy Exp $
+
+*kalzium-4.2.1 (04 Mar 2009)
+
+ 04 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.2.1.ebuild:
+ Bump KDE 4.2.1
22 Feb 2009; Carsten Lohrke <carlo@gentoo.org> kalzium-3.5.10.ebuild:
Trivial homepage change, bug #259727.
diff --git a/kde-base/kalzium/kalzium-4.2.1.ebuild b/kde-base/kalzium/kalzium-4.2.1.ebuild
new file mode 100644
index 000000000000..a49102821571
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.2.1.ebuild,v 1.1 2009/03/04 20:28:01 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="editor debug +plasma solver"
+
+DEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ editor? ( >=dev-cpp/eigen-1.0.5
+ >=sci-chemistry/openbabel-2.2 )
+ solver? ( dev-ml/facile[ocamlopt] )"
+RDEPEND="${RDEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui libkdeedu/libscience"
+
+src_configure(){
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with editor Eigen)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ sed -i -e "s:add_subdirectory(cmake):#dontwantit:g" CMakeLists.txt \
+ || die "disabling cmake includes failed"
+ sed -i -e "s:add_subdirectory( cmake ):#dontwantit:g" CMakeLists.txt \
+ || die "disabling cmake includes failed"
+
+ if use solver; then
+ # Compile the solver on its own as the cmake-based build is
+ # currently broken. Fixes bug 206620.
+ pushd "${S}/${PN}/src/solver" >/dev/null
+ emake || die "compiling the ocaml resolver failed"
+ mkdir -p "${WORKDIR}/${PN}_build/${PN}/src/"
+ cp * "${WORKDIR}/${PN}_build/${PN}/src/"
+ popd >/dev/null
+ fi
+
+ kde4-meta_src_configure
+}