summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 16:28:57 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 16:28:57 +0000
commit9bd03a1d46c998b6c6468a437ec6ac6564094136 (patch)
tree3c5086e459a60d690d2a7f5e644fa516f8feebf4 /kde-base/kalzium
parentInitial commit of screengrab application. Fixes bug #307093 (diff)
downloadhistorical-9bd03a1d46c998b6c6468a437ec6ac6564094136.tar.gz
historical-9bd03a1d46c998b6c6468a437ec6ac6564094136.tar.bz2
historical-9bd03a1d46c998b6c6468a437ec6ac6564094136.zip
Version bump KDE 4.4.1
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog8
-rw-r--r--kde-base/kalzium/kalzium-4.4.1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index ab6f78aeb90c..2bfc8ee96f0d 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.158 2010/02/20 10:01:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.159 2010/03/02 15:41:06 tampakrap Exp $
+
+*kalzium-4.4.1 (02 Mar 2010)
+
+ 02 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kalzium-4.4.1.ebuild:
+ Version bump
20 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> kalzium-4.3.5.ebuild:
amd64/x86 stable wrt #300393
diff --git a/kde-base/kalzium/kalzium-4.4.1.ebuild b/kde-base/kalzium/kalzium-4.4.1.ebuild
new file mode 100644
index 000000000000..2f36254d9399
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.4.1.ebuild,v 1.1 2010/03/02 15:41:06 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +handbook +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-meta_src_configure
+}