summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-04 01:39:24 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-04 01:39:24 +0000
commitd28d4c3ef16a1d67b8fba9625eb0f0cc1e61b927 (patch)
tree4a5e0d596c871b904ba6a9adf64b2fe4c4e8bac4 /kde-base/kalzium
parent2.2_rc35 bump. Fixes previously mentioned regression in 2.2_rc34. (diff)
downloadhistorical-d28d4c3ef16a1d67b8fba9625eb0f0cc1e61b927.tar.gz
historical-d28d4c3ef16a1d67b8fba9625eb0f0cc1e61b927.tar.bz2
historical-d28d4c3ef16a1d67b8fba9625eb0f0cc1e61b927.zip
Version bump KDE 4.3.0
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.3.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 7a03c4f26c89..417c5a5dad26 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.133 2009/07/12 11:39:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.134 2009/08/03 23:52:52 wired Exp $
+
+*kalzium-4.3.0 (03 Aug 2009)
+
+ 03 Aug 2009; Alex Alexander <wired@gentoo.org> +kalzium-4.3.0.ebuild:
+ Version bump
12 Jul 2009; Raúl Porcel <armin76@gentoo.org> kalzium-3.5.10.ebuild:
alpha/ia64/sparc stable wrt #271889
diff --git a/kde-base/kalzium/kalzium-4.3.0.ebuild b/kde-base/kalzium/kalzium-4.3.0.ebuild
new file mode 100644
index 000000000000..dc355fa711cc
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.3.0.ebuild,v 1.1 2009/08/03 23:52:52 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="editor debug +handbook +plasma solver"
+
+COMMON_DEPEND="
+ >=kde-base/libkdeedu-${PV}:${SLOT}[kdeprefix=]
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${COMMON_DEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ kde4-meta_src_configure
+}