summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-22 21:54:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-09-22 21:54:06 +0000
commit9a00a3570a816a3f827ffa49491cb829f2743d76 (patch)
treeea4931c50a390addcb9dda3b4bb8345237b96413 /kde-base/kbabel/kbabel-3.5_beta1.ebuild
parentbug 105858 , plus cleanup of autotooling. (diff)
downloadhistorical-9a00a3570a816a3f827ffa49491cb829f2743d76.tar.gz
historical-9a00a3570a816a3f827ffa49491cb829f2743d76.tar.bz2
historical-9a00a3570a816a3f827ffa49491cb829f2743d76.zip
Bump to 3.5 beta1.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'kde-base/kbabel/kbabel-3.5_beta1.ebuild')
-rw-r--r--kde-base/kbabel/kbabel-3.5_beta1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/kbabel/kbabel-3.5_beta1.ebuild b/kde-base/kbabel/kbabel-3.5_beta1.ebuild
new file mode 100644
index 000000000000..41ced58f0204
--- /dev/null
+++ b/kde-base/kbabel/kbabel-3.5_beta1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kbabel/kbabel-3.5_beta1.ebuild,v 1.1 2005/09/22 17:52:27 flameeyes Exp $
+
+KMNAME=kdesdk
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KBabel - An advanced PO file editor"
+KEYWORDS="~amd64"
+IUSE="berkdb"
+
+DEPEND="sys-devel/flex
+ berkdb? ( || ( =sys-libs/db-4.3*
+ =sys-libs/db-4.2* ) )"
+
+PATCHES1="${FILESDIR}/configure-fix-kdesdk-db-3.4.patch"
+
+src_compile() {
+ local myconf=""
+
+ if use berkdb; then
+ if has_version "=sys-libs/db-4.3*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-name=db-4.3
+ --with-db-include-dir=/usr/include/db4.3"
+ elif has_version "=sys-libs/db-4.2*"; then
+ myconf="${myconf} --with-berkeley-db --with-db-name=db-4.2
+ --with-db-include-dir=/usr/include/db4.2"
+ fi
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde_src_compile
+}