summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-06-06 14:42:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-06-06 14:42:20 +0000
commitf605b58054d9fb2d0703ebad662087446b538fed (patch)
tree6ac3418032aa83d83c1d3684befc2110a98e2092 /kde-base/kdebindings-csharp
parentarm stable wrt #300831 (diff)
downloadhistorical-f605b58054d9fb2d0703ebad662087446b538fed.tar.gz
historical-f605b58054d9fb2d0703ebad662087446b538fed.tar.bz2
historical-f605b58054d9fb2d0703ebad662087446b538fed.zip
Drop old. Version bump.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdebindings-csharp')
-rw-r--r--kde-base/kdebindings-csharp/ChangeLog9
-rw-r--r--kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild64
-rw-r--r--kde-base/kdebindings-csharp/kdebindings-csharp-4.4.4.ebuild (renamed from kde-base/kdebindings-csharp/kdebindings-csharp-4.4.2.ebuild)2
3 files changed, 9 insertions, 66 deletions
diff --git a/kde-base/kdebindings-csharp/ChangeLog b/kde-base/kdebindings-csharp/ChangeLog
index 9cbac9013576..7b84389d4a48 100644
--- a/kde-base/kdebindings-csharp/ChangeLog
+++ b/kde-base/kdebindings-csharp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdebindings-csharp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/ChangeLog,v 1.32 2010/05/25 03:44:30 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/ChangeLog,v 1.33 2010/06/06 14:41:55 scarabeus Exp $
+
+*kdebindings-csharp-4.4.4 (06 Jun 2010)
+
+ 06 Jun 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ -kdebindings-csharp-4.4.2.ebuild, -kdebindings-csharp-4.4.3.ebuild,
+ +kdebindings-csharp-4.4.4.ebuild:
+ Remove old. Version bump.
25 May 2010; Maciej Mrozowski <reavertm@gentoo.org>
kdebindings-csharp-4.4.2.ebuild, kdebindings-csharp-4.4.3.ebuild:
diff --git a/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild
deleted file mode 100644
index 235393d30266..000000000000
--- a/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.3.ebuild,v 1.3 2010/05/25 03:44:30 reavertm Exp $
-
-EAPI="3"
-
-KMNAME="kdebindings"
-KMMODULE="csharp"
-WEBKIT_REQUIRED="optional"
-inherit kde4-meta mono
-
-DESCRIPTION="C# bindings for KDE and Qt"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="akonadi +phonon plasma qimageblitz qscintilla semantic-desktop"
-
-DEPEND="
- dev-lang/mono
- $(add_kdebase_dep smoke 'akonadi?,phonon?,qimageblitz?,qscintilla?,semantic-desktop?,webkit?')
- semantic-desktop? ( >=dev-libs/soprano-2.3.73[clucene] )
-"
-RDEPEND="${DEPEND}"
-
-KMEXTRACTONLY="smoke/"
-
-PATCHES=( "${FILESDIR}"/${PN}-4.4.1-make-stuff-optional.patch )
-
-pkg_setup() {
- kde4-meta_pkg_setup
-
- if use plasma && ! use webkit; then
- eerror
- eerror "The plasma USE flag requires the webkit USE flag to be enabled."
- eerror
- eerror "Please enable webkit or disable plasma."
- die "plasma requires webkit"
- fi
-}
-
-src_prepare() {
- kde4-meta_src_prepare
-
- # Disable soprano index (clucene) bindings
- rm -f csharp/soprano/soprano/Soprano_Index_{CLuceneIndex,IndexFilterModel}.cs || die
- sed -e 's/\${SOPRANO_INDEX_LIBRARIES}//g' \
- -i csharp/soprano/CMakeLists.txt || die 'failed to remove clucene from link'
-
- sed -e "/add_subdirectory( examples )/ s:^:#:" \
- -i csharp/plasma/CMakeLists.txt || die 'failed to disable examples'
-}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with akonadi)
- $(cmake-utils_use_with akonadi KdepimLibs)
- $(cmake-utils_use_enable plasma PLASMA_SHARP)
- $(cmake-utils_use_enable phonon PHONON_SHARP)
- $(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SHARP)
- $(cmake-utils_use_enable qscintilla QSCINTILLA_SHARP)
- $(cmake-utils_use_with semantic-desktop Nepomuk)
- $(cmake-utils_use_with semantic-desktop Soprano)
- $(cmake-utils_use_enable webkit QTWEBKIT_SHARP)
- )
- kde4-meta_src_configure
-}
diff --git a/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.2.ebuild b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.4.ebuild
index 3403f4aa8350..0e85d03d0f0a 100644
--- a/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.2.ebuild
+++ b/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.2.ebuild,v 1.3 2010/05/25 03:44:30 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-csharp/kdebindings-csharp-4.4.4.ebuild,v 1.1 2010/06/06 14:41:55 scarabeus Exp $
EAPI="3"