summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-10-31 05:28:59 +0000
committerDan Armak <danarmak@gentoo.org>2002-10-31 05:28:59 +0000
commit526d0ca96dfb6d6a2802616e2d291b740ae70b6a (patch)
tree590e9c8fb1d6f5826c1eb159d8d264cd3aa9bc70 /kde-base/kdebindings
parentmask kde 3.1 rc1 (diff)
downloadhistorical-526d0ca96dfb6d6a2802616e2d291b740ae70b6a.tar.gz
historical-526d0ca96dfb6d6a2802616e2d291b740ae70b6a.tar.bz2
historical-526d0ca96dfb6d6a2802616e2d291b740ae70b6a.zip
kde 3.1 rc1
Diffstat (limited to 'kde-base/kdebindings')
-rw-r--r--kde-base/kdebindings/kdebindings-3.1_rc1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kdebindings/kdebindings-3.1_rc1.ebuild b/kde-base/kdebindings/kdebindings-3.1_rc1.ebuild
new file mode 100644
index 000000000000..3f4690ebb014
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.1_rc1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+# TODO: add gnustep, objc bindings
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - kde library bindings for languages other than c++"
+
+KEYWORDS="x86"
+
+newdepend "~kde-base/kdebase-${PV}
+ =x11-libs/gtk+-1.2*
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ ~kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+#myconf="$myconf --enable-objc"
+
+export LIBPYTHON="`python-config`"
+
+#src_unpack()
+#{
+# base_src_unpack
+#
+# if [ -z "`use mozilla`" ]; then
+# # disable mozilla bindings/xpart
+# cd ${S}
+# cp configure configure.orig
+# sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+# chmod +x configure
+# fi
+#}
+