summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
commit6010bfdb4951b252d0178466152533f87a47a205 (patch)
treec46457b1233e7a5503540b92a2ef5d8cbfd9b4dc /kde-base/kig
parentFix docs installation, bug 487448 by Juergen Rose. Add -fno-strict-aliasing t... (diff)
downloadhistorical-6010bfdb4951b252d0178466152533f87a47a205.tar.gz
historical-6010bfdb4951b252d0178466152533f87a47a205.tar.bz2
historical-6010bfdb4951b252d0178466152533f87a47a205.zip
Version bump KDE SC 4.11.2
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x42618354
Diffstat (limited to 'kde-base/kig')
-rw-r--r--kde-base/kig/ChangeLog7
-rw-r--r--kde-base/kig/kig-4.11.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kig/ChangeLog b/kde-base/kig/ChangeLog
index d671cdee6f2a..4471cb697150 100644
--- a/kde-base/kig/ChangeLog
+++ b/kde-base/kig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kig
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/ChangeLog,v 1.283 2013/09/03 19:50:07 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/ChangeLog,v 1.284 2013/10/09 23:03:57 creffett Exp $
+
+*kig-4.11.2 (08 Oct 2013)
+
+ 08 Oct 2013; Chris Reffett <creffett@gentoo.org> +kig-4.11.2.ebuild:
+ Version bump KDE SC 4.11.2
03 Sep 2013; Chris Reffett <creffett@gentoo.org> -kig-4.11.0.ebuild,
files/kig-4.11.0-boostpython.patch:
diff --git a/kde-base/kig/kig-4.11.2.ebuild b/kde-base/kig/kig-4.11.2.ebuild
new file mode 100644
index 000000000000..da259464a67e
--- /dev/null
+++ b/kde-base/kig/kig-4.11.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-4.11.2.ebuild,v 1.1 2013/10/09 23:03:57 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="http://www.kde.org/applications/education/kig http://edu.kde.org/kig"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.11.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde4-base_src_configure
+}