summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-05-01 14:03:39 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-05-01 14:03:39 +0000
commit89e4ec7707f007b9bdd81dcef61fb02483f37f72 (patch)
tree882b74508d53b0a5fb88e1098160fba982fa825b /kde-base/kmail
parentPlay nice with broken imap servers. (diff)
downloadhistorical-89e4ec7707f007b9bdd81dcef61fb02483f37f72.tar.gz
historical-89e4ec7707f007b9bdd81dcef61fb02483f37f72.tar.bz2
historical-89e4ec7707f007b9bdd81dcef61fb02483f37f72.zip
Enable full-text indexing.
Package-Manager: portage-2203-svn
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/files/digest-kmail-3.5.2-r21
-rw-r--r--kde-base/kmail/kmail-3.5.2-r2.ebuild65
3 files changed, 72 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 4bc3b675a1c3..abe4bb4a720a 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.56 2006/04/22 12:06:45 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.57 2006/05/01 14:03:39 carlo Exp $
+
+*kmail-3.5.2-r2 (01 May 2006)
+
+ 01 May 2006; Carsten Lohrke <carlo@gentoo.org> +kmail-3.5.2-r2.ebuild:
+ Enable full-text indexing.
22 Apr 2006; Markus Rothe <corsair@gentoo.org> kmail-3.5.2-r1.ebuild:
app-crypt/pinentry was keyworded for ppc64 to it can be installed with
diff --git a/kde-base/kmail/files/digest-kmail-3.5.2-r2 b/kde-base/kmail/files/digest-kmail-3.5.2-r2
new file mode 100644
index 000000000000..9ee81dd048d6
--- /dev/null
+++ b/kde-base/kmail/files/digest-kmail-3.5.2-r2
@@ -0,0 +1 @@
+MD5 ac6b3b503e27a65a7b883c1e0a57262e kdepim-3.5.2.tar.bz2 12887336
diff --git a/kde-base/kmail/kmail-3.5.2-r2.ebuild b/kde-base/kmail/kmail-3.5.2-r2.ebuild
new file mode 100644
index 000000000000..231ea8e0884b
--- /dev/null
+++ b/kde-base/kmail/kmail-3.5.2-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-3.5.2-r2.ebuild,v 1.1 2006/05/01 14:03:39 carlo Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE mail client"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="$(deprange 3.5.0-r3 $MAXKDEVER kde-base/libkdenetwork)
+ $(deprange $PV $MAXKDEVER kde-base/libkdepim)
+ $(deprange $PV $MAXKDEVER kde-base/libkpimidentities)
+ $(deprange 3.5.1 $MAXKDEVER kde-base/mimelib)
+ $(deprange 3.5.0-r3 $MAXKDEVER kde-base/libksieve)
+ $(deprange $PV $MAXKDEVER kde-base/certmanager)
+ $(deprange $PV $MAXKDEVER kde-base/libkcal)
+ $(deprange $PV $MAXKDEVER kde-base/kontact)"
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )
+ $(deprange $PV $MAXKDEVER kde-base/kdepim-kioslaves)
+ $(deprange 3.5.1 $MAXKDEVER kde-base/kmailcvt)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kdebase-kioslaves)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)" # for the "looknfeel" icon, and probably others.
+
+KMCOPYLIB="
+ libkdepim libkdepim/
+ libkpimidentities libkpimidentities/
+ libmimelib mimelib/
+ libksieve libksieve/
+ libkleopatra certmanager/lib/
+ libkcal libkcal
+ libkpinterfaces kontact/interfaces/
+ libkmime libkmime
+ libkpgp libkpgp"
+KMEXTRACTONLY="
+ libkdenetwork/
+ libkdepim/
+ libkpimidentities/
+ libksieve/
+ libkcal/
+ mimelib/
+ certmanager/
+ korganizer/korganizeriface.h
+ kontact/interfaces/
+ libkmime/
+ libkpgp
+ dcopidlng"
+KMCOMPILEONLY="libemailfunctions"
+# the kmail plugins are installed with kmail
+KMEXTRA="indexlib
+ plugins/kmail/
+ kontact/plugins/kmail/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+PATCHES="${FILESDIR}/kmail-3.5.2-imap-fixes.diff
+ ${FILESDIR}/kmail-3.5.2-misc-fixes.diff
+ ${FILESDIR}/kmail-3.5-ham_spam_icons.diff" # This patch did not make it into svn, yet.
+
+
+src_compile() {
+ myconf="--enable-indexlib"
+ kde-meta_src_compile
+} \ No newline at end of file