summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-01-25 17:45:10 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-01-25 17:45:10 +0000
commitc552594ca5cc5e4e460e3b5ca86e57f1d8bef656 (patch)
tree54a346c20039e1ea40108fab92ae3e438743c4e5 /kde-base/kpilot
parentVersion bump. Drop older. (diff)
downloadhistorical-c552594ca5cc5e4e460e3b5ca86e57f1d8bef656.tar.gz
historical-c552594ca5cc5e4e460e3b5ca86e57f1d8bef656.tar.bz2
historical-c552594ca5cc5e4e460e3b5ca86e57f1d8bef656.zip
Version bump KDE 4.3.5
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog7
-rw-r--r--kde-base/kpilot/kpilot-4.3.5.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index ce524b099e77..8fa52309650f 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kpilot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.111 2010/01/23 20:19:11 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.112 2010/01/25 16:36:50 scarabeus Exp $
+
+*kpilot-4.3.5 (25 Jan 2010)
+
+ 25 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org> +kpilot-4.3.5.ebuild:
+ Version bump
23 Jan 2010; Jonathan Callen <abcd@gentoo.org> kpilot-4.3.4.ebuild:
Keyword ~amd64-linux/~x86-linux
diff --git a/kde-base/kpilot/kpilot-4.3.5.ebuild b/kde-base/kpilot/kpilot-4.3.5.ebuild
new file mode 100644
index 000000000000..87b78dd79cdb
--- /dev/null
+++ b/kde-base/kpilot/kpilot-4.3.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-4.3.5.ebuild,v 1.1 2010/01/25 16:36:50 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KPilot is software for syncing PalmOS based handhelds."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="avantgo crypt debug +handbook"
+
+DEPEND="
+ >=app-pda/pilot-link-0.12
+ $(add_kdebase_dep libkdepim)
+ avantgo? ( >=dev-libs/libmal-0.40 )
+ crypt? ( app-crypt/qca:2 )
+"
+RDEPEND="${DEPEND}"
+
+# Tests hang, last checked in 4.3.3
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with avantgo Mal)
+ $(cmake-utils_use_with crypt QCA2)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test (as of 4.2.87)
+ sed -i -e '/keyringcategorysynctest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/conduits/keyringconduit/tests/CMakeLists.txt || \
+ die "sed to disable keyringcategorysynctest failed."
+
+ kde4-meta_src_test
+}