summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-20 00:00:37 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-20 00:00:37 +0000
commit6956f78ffe03ad38ca9fc672ab1b983dd8071ee5 (patch)
treec8c8fdb5e0506fadb5ceae32d57ead0b07c77f6f /kde-base/kttsd
parentVersion bump, bug #195981 (diff)
downloadhistorical-6956f78ffe03ad38ca9fc672ab1b983dd8071ee5.tar.gz
historical-6956f78ffe03ad38ca9fc672ab1b983dd8071ee5.tar.bz2
historical-6956f78ffe03ad38ca9fc672ab1b983dd8071ee5.zip
Bump to KDE 3.5.8.
Package-Manager: portage-2.1.3.15
Diffstat (limited to 'kde-base/kttsd')
-rw-r--r--kde-base/kttsd/ChangeLog7
-rw-r--r--kde-base/kttsd/files/digest-kttsd-3.5.83
-rw-r--r--kde-base/kttsd/kttsd-3.5.8.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/kttsd/ChangeLog b/kde-base/kttsd/ChangeLog
index 48f41911e4b6..3d0331516500 100644
--- a/kde-base/kttsd/ChangeLog
+++ b/kde-base/kttsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kttsd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.75 2007/08/30 17:11:45 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/ChangeLog,v 1.76 2007/10/19 23:40:40 philantrop Exp $
+
+*kttsd-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org> +kttsd-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
30 Aug 2007; Samuli Suominen <drac@gentoo.org> kttsd-3.5.5.ebuild,
kttsd-3.5.6.ebuild, kttsd-3.5.7.ebuild:
diff --git a/kde-base/kttsd/files/digest-kttsd-3.5.8 b/kde-base/kttsd/files/digest-kttsd-3.5.8
new file mode 100644
index 000000000000..fd29edc89bb3
--- /dev/null
+++ b/kde-base/kttsd/files/digest-kttsd-3.5.8
@@ -0,0 +1,3 @@
+MD5 0ede2d48df626aa436dbe6c741d575f1 kdeaccessibility-3.5.8.tar.bz2 8749116
+RMD160 206bf15f794217f968aea06a4653a6d0f168137c kdeaccessibility-3.5.8.tar.bz2 8749116
+SHA256 1b888b1c9c5196a7ef2aac3fcd18e5e013fb5576ed5d7f98a829f9a0ac9b65ac kdeaccessibility-3.5.8.tar.bz2 8749116
diff --git a/kde-base/kttsd/kttsd-3.5.8.ebuild b/kde-base/kttsd/kttsd-3.5.8.ebuild
new file mode 100644
index 000000000000..b340661325d1
--- /dev/null
+++ b/kde-base/kttsd/kttsd-3.5.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kttsd/kttsd-3.5.8.ebuild,v 1.1 2007/10/19 23:40:40 philantrop Exp $
+KMNAME=kdeaccessibility
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE text-to-speech subsystem"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="akode alsa"
+DEPEND="akode? ( media-libs/akode )
+ alsa? ( media-libs/alsa-lib )
+ $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)
+ !arts? ( !alsa? ( media-libs/akode ) )"
+
+RDEPEND="${DEPEND}
+ || ( app-accessibility/festival
+ app-accessibility/epos
+ app-accessibility/flite
+ app-accessibility/freetts )"
+
+pkg_setup() {
+ kde_pkg_setup
+ if ! use arts && ! use alsa && ! use akode ; then
+ ewarn "No audio backend chosen. Defaulting to media-libs/akode."
+ fi
+}
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ sed -i -e "s:^MimeTypes=::" "${S}/kttsd/kttsmgr/kttsmgr.desktop" \
+ || die "sed to fix the desktop file failed"
+}
+
+src_compile() {
+ local myconf="$(use_with alsa) --without-gstreamer"
+
+ if ! use arts && ! use alsa ; then
+ myconf="${myconf} --with-akokde"
+ else
+ myconf="${myconf} $(use_with akode)"
+ fi
+
+ kde-meta_src_compile
+}