summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
commit881e446ad159543c84e6f5710f10814c66f875f3 (patch)
treefb5718e17dbc5a4f0b570ece0495be9a82fb2ced /kde-base/marble/marble-4.9.0.ebuild
parentversion bump for bug 424525, ebuild provided by Ortwin Glück (diff)
downloadhistorical-881e446ad159543c84e6f5710f10814c66f875f3.tar.gz
historical-881e446ad159543c84e6f5710f10814c66f875f3.tar.bz2
historical-881e446ad159543c84e6f5710f10814c66f875f3.zip
Version bump KDE SC 4.9.0
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'kde-base/marble/marble-4.9.0.ebuild')
-rw-r--r--kde-base/marble/marble-4.9.0.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/kde-base/marble/marble-4.9.0.ebuild b/kde-base/marble/marble-4.9.0.ebuild
new file mode 100644
index 000000000000..88acf3d174c4
--- /dev/null
+++ b/kde-base/marble/marble-4.9.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/marble-4.9.0.ebuild,v 1.1 2012/08/01 22:17:31 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_REQUIRED="optional"
+CPPUNIT_REQUIRED="optional"
+PYTHON_DEPEND="python? 2"
+KDE_SCM="git"
+inherit kde4-base python
+
+DESCRIPTION="Generic geographical map widget"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug designer-plugin gps +kde plasma python"
+
+# tests fail / segfault. Last checked for 4.2.88
+# RESTRICT=test
+
+DEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-script:4
+ x11-libs/qt-webkit:4
+ gps? ( >=sci-geosciences/gpsd-2.95[qt4] )
+ python? (
+ >=dev-python/PyQt4-4.4.4-r1
+ kde? ( $(add_kdebase_dep pykde4) )
+ )
+"
+RDEPEND="${DEPEND}
+"
+# the qt dependencies are needed because with USE=-kde nothing is pulled in
+# by default... bug 414165
+
+REQUIRED_USE="
+ plasma? ( kde )
+ python? ( kde )
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ kde4-base_pkg_setup
+ python_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+ python_convert_shebangs -r $(python_get_version) .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with designer-plugin DESIGNER_PLUGIN)
+ $(cmake-utils_use python EXPERIMENTAL_PYTHON_BINDINGS)
+ $(cmake-utils_use_with python PyQt4)
+ $(cmake-utils_use_with python PythonLibrary)
+ $(cmake-utils_use_with python SIP)
+ $(cmake-utils_use_with gps libgps)
+ $(cmake-utils_use !kde QTONLY)
+ $(cmake-utils_use_with plasma)
+ -DWITH_liblocation=0
+ $(use kde && cmake-utils_use_with python PyKDE4)
+ )
+
+ kde4-base_src_configure
+}
+
+src_test() {
+ if use kde; then
+ elog "Marble tests can only be run in the qt-only version"
+ else
+ kde4-base_src_test
+ fi
+}