summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
commit069ac1542ef075cd556dfbb8d0e420eae342dc39 (patch)
tree1dd564f7adb4f21ca4525760daf1f3d100ef29ae /kde-base/smokeqt
parentMark stable for amd64/x86 per bug #415255 (diff)
downloadhistorical-069ac1542ef075cd556dfbb8d0e420eae342dc39.tar.gz
historical-069ac1542ef075cd556dfbb8d0e420eae342dc39.tar.bz2
historical-069ac1542ef075cd556dfbb8d0e420eae342dc39.zip
KDE 4.8.4 version bump
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/ChangeLog7
-rw-r--r--kde-base/smokeqt/smokeqt-4.8.4.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/kde-base/smokeqt/ChangeLog b/kde-base/smokeqt/ChangeLog
index 3569ff2b5da9..1589ea94d7fd 100644
--- a/kde-base/smokeqt/ChangeLog
+++ b/kde-base/smokeqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smokeqt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.27 2012/05/24 11:38:03 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/ChangeLog,v 1.28 2012/06/21 21:54:31 dilfridge Exp $
+
+*smokeqt-4.8.4 (21 Jun 2012)
+
+ 21 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org> +smokeqt-4.8.4.ebuild:
+ Version bump KDE SC 4.8.4
24 May 2012; Johannes Huber <johu@gentoo.org> -smokeqt-4.8.1.ebuild:
Remove KDE SC 4.8.1
diff --git a/kde-base/smokeqt/smokeqt-4.8.4.ebuild b/kde-base/smokeqt/smokeqt-4.8.4.ebuild
new file mode 100644
index 000000000000..c43824ec493f
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.8.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokeqt/smokeqt-4.8.4.ebuild,v 1.1 2012/06/21 21:54:31 dilfridge Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-test:4
+ phonon? ( >=media-libs/phonon-4.4.3 )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+ webkit? ( x11-libs/qt-webkit:4 )
+"
+RDEPEND="${DEPEND}"
+
+# Split in 4.7
+add_blocker smoke
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}