summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-11-12 08:37:00 +0000
committerTim Harder <radhermit@gentoo.org>2010-11-12 08:37:00 +0000
commit963f650e59da91a682f2a466bf3a9e766b07896c (patch)
treecee941fcb575ae6bff9d630819cdb4d8ae99a784 /mail-client/cone/cone-0.84.20100819-r1.ebuild
parentRemoved old (diff)
downloadhistorical-963f650e59da91a682f2a466bf3a9e766b07896c.tar.gz
historical-963f650e59da91a682f2a466bf3a9e766b07896c.tar.bz2
historical-963f650e59da91a682f2a466bf3a9e766b07896c.zip
Revision bump and remove old. Fix aspell automagic dependency (bug #344329 by Cyprien Nicolas).
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'mail-client/cone/cone-0.84.20100819-r1.ebuild')
-rw-r--r--mail-client/cone/cone-0.84.20100819-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/mail-client/cone/cone-0.84.20100819-r1.ebuild b/mail-client/cone/cone-0.84.20100819-r1.ebuild
new file mode 100644
index 000000000000..c877eab64ca6
--- /dev/null
+++ b/mail-client/cone/cone-0.84.20100819-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/cone-0.84.20100819-r1.ebuild,v 1.1 2010/11/12 08:37:00 radhermit Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="CONE: COnsole News reader and Emailer"
+HOMEPAGE="http://www.courier-mta.org/cone/"
+SRC_URI="mirror://sourceforge/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crypt fam gnutls idn ipv6 ldap spell"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ dev-libs/libxml2
+ sys-libs/ncurses
+ crypt? ( >=app-crypt/gnupg-1.0.4 )
+ fam? ( virtual/fam )
+ gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ ipv6? ( net-dns/libidn )
+ ldap? ( net-nds/openldap )
+ spell? ( virtual/aspell-dict )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-aspell-automagic.patch
+
+ cd cone
+ LIBTOOLIZE="true" eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use spell ; then
+ myconf="--with-spellcheck=aspell"
+ else
+ myconf="--with-spellcheck=none"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_with ldap ldapaddressbook) \
+ $(use_with gnutls) \
+ $(use_with idn libidn) \
+ $(use_with ipv6)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install-configure || die "emake install-configure failed"
+}