summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2005-11-13 20:15:21 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2005-11-13 20:15:21 +0000
commit16b0d26c97ab7e03a4df27bda03ffa1a0ef6e3e6 (patch)
tree9b28e78f63c5144db8c3951a9b7d67bd6bb94800 /mail-client
parentstable on alpha wrt bug #112063 (diff)
downloadhistorical-16b0d26c97ab7e03a4df27bda03ffa1a0ef6e3e6.tar.gz
historical-16b0d26c97ab7e03a4df27bda03ffa1a0ef6e3e6.tar.bz2
historical-16b0d26c97ab7e03a4df27bda03ffa1a0ef6e3e6.zip
Fix a compilation issue using the 32-bit userland with 64-bit kernel on PowerPC.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mozilla-thunderbird/ChangeLog7
-rw-r--r--mail-client/mozilla-thunderbird/Manifest4
-rw-r--r--mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild12
3 files changed, 19 insertions, 4 deletions
diff --git a/mail-client/mozilla-thunderbird/ChangeLog b/mail-client/mozilla-thunderbird/ChangeLog
index 924403c065d7..9359c52d09c4 100644
--- a/mail-client/mozilla-thunderbird/ChangeLog
+++ b/mail-client/mozilla-thunderbird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/mozilla-thunderbird
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.91 2005/10/25 21:55:41 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/ChangeLog,v 1.92 2005/11/13 20:15:21 hansmi Exp $
+
+ 13 Nov 2005; Michael Hanselmann <hansmi@gentoo.org>
+ mozilla-thunderbird-1.0.7-r2.ebuild:
+ Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ PowerPC.
*mozilla-thunderbird-1.0.7-r2 (26 Oct 2005)
diff --git a/mail-client/mozilla-thunderbird/Manifest b/mail-client/mozilla-thunderbird/Manifest
index 71cfc412627e..a59dc576e031 100644
--- a/mail-client/mozilla-thunderbird/Manifest
+++ b/mail-client/mozilla-thunderbird/Manifest
@@ -1,4 +1,4 @@
-MD5 4822d36edf72d8770da1b3208ec800bb ChangeLog 13463
+MD5 3c0c85cd4b91a631e0e7b2e167073c61 ChangeLog 13641
MD5 b84b32e9963589c0f2f76d98019b44d7 files/digest-mozilla-thunderbird-1.0.7 303
MD5 34fc13a505bfb805c539a3b4f0b1bcbf files/digest-mozilla-thunderbird-1.0.7-r1 303
MD5 106701e2f4e5e9e73301f95dd92c3306 files/digest-mozilla-thunderbird-1.0.7-r2 227
@@ -10,5 +10,5 @@ MD5 1783f8e4678fb4731ccc67b4bfba1981 files/mozilla-thunderbird-1.0.7-gcc-4.0.2.p
MD5 07f9a980afa2dde67554657c00b8be18 files/thunderbird-rpath-1.patch 1716
MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
MD5 2896cc99ffbb38fe463d98feb1e954f0 mozilla-thunderbird-1.0.7-r1.ebuild 5640
-MD5 6b541a64f149c93f7448bff5da647068 mozilla-thunderbird-1.0.7-r2.ebuild 5694
+MD5 0ef89d2954584a386d1d201ebecb465c mozilla-thunderbird-1.0.7-r2.ebuild 6095
MD5 55697b53bd932c2ea9c20d3d5e3b771e mozilla-thunderbird-1.0.7.ebuild 5632
diff --git a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild
index 4b43ee0df6c3..5344e1a5e9cc 100644
--- a/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild
+++ b/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild,v 1.1 2005/10/25 21:55:41 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mozilla-thunderbird/mozilla-thunderbird-1.0.7-r2.ebuild,v 1.2 2005/11/13 20:15:21 hansmi Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic toolchain-funcs eutils mozconfig mozilla-launcher makeedit multilib
@@ -65,6 +65,16 @@ src_unpack() {
# freetype; this enables freetype-2.1.8+ compat.
# https://bugzilla.mozilla.org/show_bug.cgi?id=234035#c65
epatch ${DISTDIR}/mozilla-firefox-1.0-4ft2.patch.bz2
+
+ # Fix a compilation issue using the 32-bit userland with 64-bit kernel on
+ # PowerPC, because with that configuration, it detects a ppc64 system.
+ # -- hansmi, 2005-11-13
+ if use ppc && [[ "${PROFILE_ARCH}" == ppc64 ]]; then
+ sed -i -e "s#OS_TEST=\`uname -m\`\$#OS_TEST=${ARCH}#" \
+ ${S}/configure
+ sed -i -e "s#OS_TEST :=.*uname -m.*\$#OS_TEST:=${ARCH}#" \
+ ${S}/security/coreconf/arch.mk
+ fi
}
src_compile() {