summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-12-22 15:41:31 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-12-22 15:41:31 +0000
commit75fd9ab8692b7e37a431fdefda856cb800dd3eec (patch)
treef8cc950f176737613ea5dd24171b7e345067325a /media-gfx/blender/files
parentRevbump to apply security patch. Thanks to Corentin LABBE (diff)
downloadhistorical-75fd9ab8692b7e37a431fdefda856cb800dd3eec.tar.gz
historical-75fd9ab8692b7e37a431fdefda856cb800dd3eec.tar.bz2
historical-75fd9ab8692b7e37a431fdefda856cb800dd3eec.zip
add missing patches
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0xBDEED020
Diffstat (limited to 'media-gfx/blender/files')
-rw-r--r--media-gfx/blender/files/blender-2.68-doxyfile.patch19
-rw-r--r--media-gfx/blender/files/blender-2.68-fix-install-rules.patch26
-rw-r--r--media-gfx/blender/files/blender-2.70-sse2.patch35
3 files changed, 80 insertions, 0 deletions
diff --git a/media-gfx/blender/files/blender-2.68-doxyfile.patch b/media-gfx/blender/files/blender-2.68-doxyfile.patch
new file mode 100644
index 000000000000..c11c793fda97
--- /dev/null
+++ b/media-gfx/blender/files/blender-2.68-doxyfile.patch
@@ -0,0 +1,19 @@
+commit 62308d9fc24bde22a50497816c44c8ca91f96f63
+Author: hasufell <hasufell@gentoo.org>
+Date: Fri Jul 19 18:36:34 2013 +0200
+
+ remove hhc.exe reference
+
+diff --git a/doc/doxygen/Doxyfile b/doc/doxygen/Doxyfile
+index 397cc30..ac61756 100644
+--- a/doc/doxygen/Doxyfile
++++ b/doc/doxygen/Doxyfile
+@@ -1051,7 +1051,7 @@ CHM_FILE = blender.chm
+ # the HTML help compiler (hhc.exe). If non-empty doxygen will try to run
+ # the HTML help compiler on the generated index.hhp.
+
+-HHC_LOCATION = "C:/Program Files (x86)/HTML Help Workshop/hhc.exe"
++HHC_LOCATION =
+
+ # If the GENERATE_HTMLHELP tag is set to YES, the GENERATE_CHI flag
+ # controls if a separate .chi index file is generated (YES) or that
diff --git a/media-gfx/blender/files/blender-2.68-fix-install-rules.patch b/media-gfx/blender/files/blender-2.68-fix-install-rules.patch
new file mode 100644
index 000000000000..aa8ecc9f6174
--- /dev/null
+++ b/media-gfx/blender/files/blender-2.68-fix-install-rules.patch
@@ -0,0 +1,26 @@
+commit 94eed33f878e35a8c7b69b0c23b3b30026460f33
+Author: hasufell <hasufell@gentoo.org>
+Date: Fri Jul 19 18:50:08 2013 +0200
+
+ remove stupid uninstall snippet
+
+ whoever coded this... it is dangerous
+ uninstall methods have NO PLACE in install rules
+
+diff --git a/source/creator/CMakeLists.txt b/source/creator/CMakeLists.txt
+index c84d944..2b9bf46 100644
+--- a/source/creator/CMakeLists.txt
++++ b/source/creator/CMakeLists.txt
+@@ -268,12 +268,6 @@ endif()
+ # Install Targets (Generic, All Platforms)
+
+
+-# important to make a clean install each time, else old scripts get loaded.
+-install(
+- CODE
+- "file(REMOVE_RECURSE ${TARGETDIR_VER})"
+-)
+-
+ if(WITH_PYTHON)
+ # install(CODE "message(\"copying blender scripts...\")")
+
diff --git a/media-gfx/blender/files/blender-2.70-sse2.patch b/media-gfx/blender/files/blender-2.70-sse2.patch
new file mode 100644
index 000000000000..6fc870ea3258
--- /dev/null
+++ b/media-gfx/blender/files/blender-2.70-sse2.patch
@@ -0,0 +1,35 @@
+commit 0e0b27a589680e10e38a26575ad4dba8f3af2ec6
+Author: hasufell <hasufell@gentoo.org>
+Date: Fri Jul 19 18:50:19 2013 +0200
+
+ add option to explicitly control sse2 optimization
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 78bb3c6..d5f4576 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -86,6 +86,7 @@
+ #-----------------------------------------------------------------------------
+ # Load some macros.
+ include(build_files/cmake/macros.cmake)
++include(CMakeDependentOption)
+
+
+ #-----------------------------------------------------------------------------
+@@ -251,6 +252,7 @@
+ # Misc
+ option(WITH_INPUT_NDOF "Enable NDOF input devices (SpaceNavigator and friends)" ON)
+ option(WITH_RAYOPTIMIZATION "Enable use of SIMD (SSE) optimizations for the raytracer" ON)
++cmake_dependent_option(WITH_SSE2 "SSE2 optimizations" ON WITH_RAYOPTIMIZATION OFF)
+ option(WITH_OPENNL "Enable use of Open Numerical Library" ON)
+ if(UNIX AND NOT APPLE)
+ option(WITH_INSTALL_PORTABLE "Install redistributeable runtime, otherwise install into CMAKE_INSTALL_PREFIX" ON)
+@@ -1950,7 +1952,7 @@
+ set(PLATFORM_CFLAGS " ${COMPILER_SSE_FLAG} ${PLATFORM_CFLAGS}")
+ add_definitions(-D__SSE__ -D__MMX__)
+ endif()
+- if(SUPPORT_SSE2_BUILD)
++ if(WITH_SSE2 AND SUPPORT_SSE2_BUILD)
+ set(PLATFORM_CFLAGS " ${COMPILER_SSE2_FLAG} ${PLATFORM_CFLAGS}")
+ add_definitions(-D__SSE2__)
+ if(NOT SUPPORT_SSE_BUILD) # dont double up