summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-09-26 19:05:02 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-09-26 19:05:02 +0000
commit77091b025c5563daf268d5b6123e2ce9e7329ad2 (patch)
tree84f7ae2bdc0f924d1142bd04ae3cdbb669da4e3b /media-gfx/gimp-print
parentversion bump (diff)
downloadhistorical-77091b025c5563daf268d5b6123e2ce9e7329ad2.tar.gz
historical-77091b025c5563daf268d5b6123e2ce9e7329ad2.tar.bz2
historical-77091b025c5563daf268d5b6123e2ce9e7329ad2.zip
version bump
Diffstat (limited to 'media-gfx/gimp-print')
-rw-r--r--media-gfx/gimp-print/Manifest4
-rw-r--r--media-gfx/gimp-print/files/digest-gimp-print-4.3.211
-rw-r--r--media-gfx/gimp-print/gimp-print-4.3.21.ebuild92
3 files changed, 95 insertions, 2 deletions
diff --git a/media-gfx/gimp-print/Manifest b/media-gfx/gimp-print/Manifest
index cfbb0ef44e2c..cbf27a388c64 100644
--- a/media-gfx/gimp-print/Manifest
+++ b/media-gfx/gimp-print/Manifest
@@ -1,8 +1,8 @@
MD5 3aa4758768e5a4ac6aecfee8f5d70af4 gimp-print-4.2.5-r2.ebuild 2207
-MD5 36d5869c2413b7f083939a4764347c8c gimp-print-4.3.21.ebuild 2539
+MD5 2c2c43cbfaed773b5c98143f8f0b1743 gimp-print-4.3.21.ebuild 2539
MD5 63bfc8e19e3aef79f807b08cf246930e gimp-print-4.3.19.ebuild 2539
MD5 36d5869c2413b7f083939a4764347c8c gimp-print-4.3.20.ebuild 2539
-MD5 e9427448eb10f11525b93285dcd83e9a ChangeLog 3794
+MD5 0122843ba9fc7f1c958ce1ce7bfe67ed ChangeLog 3794
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 a4a699ade9e80e084cdb33947c9fdf18 gimp-print-4.3.18.ebuild 2533
MD5 68cc29ffb32d107b59d0ab6407a7613e files/digest-gimp-print-4.2.5-r2 69
diff --git a/media-gfx/gimp-print/files/digest-gimp-print-4.3.21 b/media-gfx/gimp-print/files/digest-gimp-print-4.3.21
new file mode 100644
index 000000000000..f1ba66425069
--- /dev/null
+++ b/media-gfx/gimp-print/files/digest-gimp-print-4.3.21
@@ -0,0 +1 @@
+MD5 e207c50fe481f3dd8a16e29232b3970a gimp-print-4.3.21.tar.bz2 4101515
diff --git a/media-gfx/gimp-print/gimp-print-4.3.21.ebuild b/media-gfx/gimp-print/gimp-print-4.3.21.ebuild
new file mode 100644
index 000000000000..b7c8142aa0bd
--- /dev/null
+++ b/media-gfx/gimp-print/gimp-print-4.3.21.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.3.21.ebuild,v 1.1 2003/09/26 19:04:56 lanius Exp $
+
+IUSE="nls gtk readline cups foomaticdb ppds"
+
+DESCRIPTION="Gimp Print Drivers"
+HOMEPAGE="http://gimp-print.sourceforge.net"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64"
+SRC_URI="mirror://sourceforge/gimp-print/${P}.tar.bz2"
+
+DEPEND="cups? ( >=net-print/cups-1.1.14 )
+ media-gfx/imagemagick
+ >=app-text/ghostscript-7.05.6-r3
+ sys-libs/readline
+ gtk? ( =x11-libs/gtk+-1.2* )
+ dev-lang/perl
+ !media-gfx/gimp-print-cups
+ foomaticdb? ( net-print/foomatic-db-engine )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile() {
+ local myconf
+
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ use gtk \
+ && myconf="${myconf} --enable-lexmarkutil" \
+ || myconf="${myconf} --disable-lexmarkutil"
+
+ has_version =media-gfx/gimp-1.2* \
+ && myconf="${myconf} --with-gimp" \
+ || myconf="${myconf} --without-gimp"
+
+ if [ `use cups` ]; then
+ myconf="${myconf} --with-cups"
+ else
+ myconf="${myconf} --without-cups"
+ fi
+
+ if [ "`use cups`" -a "`use ppds`" ]; then
+ myconf="${myconf} --enable-cups-ppds"
+ else
+ myconf="${myconf} --disable-cups-ppds"
+ fi
+
+ use foomaticdb \
+ && myconf="${myconf} --with-foomatic3" \
+ || myconf="${myconf} --without-foomatic"
+
+ # --without-translated-ppds enabled \
+ econf \
+ --enable-test \
+ --with-ghostscript \
+ --with-user-guide \
+ --with-samples \
+ --with-escputil \
+ $myconf || die
+
+ # IJS Patch
+ cp src/ghost/ijsgimpprint.c src/ghost/ijsgimpprint.c.org
+ sed -e "s/<ijs/<ijs\/ijs/g" src/ghost/ijsgimpprint.c.org > src/ghost/ijsgimpprint.c
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ make install DESTDIR=${D} || die
+
+ exeinto /usr/share/gimp-print
+ doexe test/{unprint,pcl-unprint,bjc-unprint,parse-escp2,curve,escp2-weavetest,run-testdither,run-weavetest,testdither}
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README \
+ doc/users_guide/users-guide.ps doc/users_guide/users-guide.pdf \
+ ${D}/usr/share/gimp-print/doc/gimpprint.ps
+ dohtml doc/FAQ.html
+ dohtml -r doc/users_guide/html doc/developer/developer-html
+ rm -fR ${D}/usr/share/gimp-print/doc
+}
+
+pkg_postinst () {
+ einfo "The gimp-print ebuild no longer creates the ppds automatically, please use foomatic"
+ einfo "to do so or remerge gimp-print with the ppds use flag."
+}