summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-01-30 12:01:46 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-01-30 12:01:46 +0000
commit8fe77e3e628e2734bb7b8f9c8bd3c220b5281351 (patch)
treec980bd287b7d162a61e436eaaca5508e1ef0bb76 /media-gfx/mandelbulber/files
parentDon't call prepalldocs, it is no longer needed with EAPI 4. (diff)
downloadhistorical-8fe77e3e628e2734bb7b8f9c8bd3c220b5281351.tar.gz
historical-8fe77e3e628e2734bb7b8f9c8bd3c220b5281351.tar.bz2
historical-8fe77e3e628e2734bb7b8f9c8bd3c220b5281351.zip
Initial import. Ebuild written by me.
Package-Manager: portage-2.2.0_alpha19/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/mandelbulber/files')
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-0.97-qa.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/mandelbulber/files/mandelbulber-0.97-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-0.97-qa.patch
new file mode 100644
index 000000000000..316e33685c70
--- /dev/null
+++ b/media-gfx/mandelbulber/files/mandelbulber-0.97-qa.patch
@@ -0,0 +1,30 @@
+--- src/Release/makefile.orig 2011-01-30 12:17:24.774427282 +0100
++++ src/Release/makefile 2011-01-30 12:19:06.741766666 +0100
+@@ -43,7 +43,7 @@
+ mandelbulber: $(OBJS) $(USER_OBJS)
+ @echo 'Building target: $@'
+ @echo 'Invoking: GCC C++ Linker'
+- g++ `pkg-config --libs gtk+-2.0 gthread-2.0` -o"mandelbulber" $(OBJS) $(USER_OBJS) $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o "mandelbulber" $(OBJS) $(USER_OBJS) `pkg-config --libs gtk+-2.0 gthread-2.0` $(LIBS)
+ @echo 'Finished building target: $@'
+ @echo ' '
+
+--- src/Release/subdir.mk.orig 2011-01-30 12:18:22.699456900 +0100
++++ src/Release/subdir.mk 2011-01-30 12:18:50.772927083 +0100
+@@ -65,14 +65,14 @@
+ Render3D.o: ../Render3D.cpp
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C++ Compiler'
+- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"Render3D.d" -o"$@" "$<"
++ $(CXX) $(CXXFLAGS) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"Render3D.d" -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+
+ %.o: ../%.cpp
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C++ Compiler'
+- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
++ $(CXX) $(CXXFLAGS) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+