summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-02-08 07:20:54 +0000
committerTim Harder <radhermit@gentoo.org>2014-02-08 07:20:54 +0000
commitb3deba23ef46f98eac826dff03a50316754d9470 (patch)
treec7befb8f722136e3eb7f7aca6d2db97211f3907e /media-gfx/mandelbulber/files
parentBump (diff)
downloadhistorical-b3deba23ef46f98eac826dff03a50316754d9470.tar.gz
historical-b3deba23ef46f98eac826dff03a50316754d9470.tar.bz2
historical-b3deba23ef46f98eac826dff03a50316754d9470.zip
Version bump, install desktop file (bug #496042).
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'media-gfx/mandelbulber/files')
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch
new file mode 100644
index 000000000000..6fea9525cfe1
--- /dev/null
+++ b/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch
@@ -0,0 +1,30 @@
+--- mandelbulber1.21-1.orig/makefiles/makefile
++++ mandelbulber1.21-1.orig/makefiles/makefile
+@@ -5,6 +5,7 @@
+ -include ../makefile.init
+
+ RM := rm -rf
++CXX ?= g++
+
+ # All of the sources participating in the build are defined here
+ -include sources.mk
+@@ -44,7 +45,7 @@
+ mandelbulber: $(OBJS) $(USER_OBJS)
+ @echo 'Building target: $@'
+ @echo 'Invoking: GCC C++ Linker'
+- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) $(OBJS) $(USER_OBJS) $(LIBS)
++ $(CXX) -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) $(OBJS) $(USER_OBJS) $(LIBS)
+ @echo 'Finished building target: $@'
+ @echo ' '
+
+--- mandelbulber1.21-1.orig/makefiles/src/subdir.mk
++++ mandelbulber1.21-1.orig/makefiles/src/subdir.mk
+@@ -71,7 +71,7 @@
+ src/%.o: ../src/%.cpp
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C++ Compiler'
+- g++ -O3 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" $(CXXFLAGS) $(CPPFLAGS) -o"$@" "$<"
++ $(CXX) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" $(CXXFLAGS) $(CPPFLAGS) -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+