summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-19 08:07:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-19 08:07:03 +0000
commit00d24decaac5d53802afc1aad133cb738b8fd5a5 (patch)
tree52ee9faa452125d70e02999e8532c3c436b89f94 /media-gfx/yafray/yafray-0.0.4.ebuild
parentinitial commit (bug 22488) (diff)
downloadhistorical-00d24decaac5d53802afc1aad133cb738b8fd5a5.tar.gz
historical-00d24decaac5d53802afc1aad133cb738b8fd5a5.tar.bz2
historical-00d24decaac5d53802afc1aad133cb738b8fd5a5.zip
initial commit (bug 22488)
Diffstat (limited to 'media-gfx/yafray/yafray-0.0.4.ebuild')
-rw-r--r--media-gfx/yafray/yafray-0.0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/yafray/yafray-0.0.4.ebuild b/media-gfx/yafray/yafray-0.0.4.ebuild
new file mode 100644
index 000000000000..fdff4800b276
--- /dev/null
+++ b/media-gfx/yafray/yafray-0.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/yafray-0.0.4.ebuild,v 1.1 2003/10/19 08:07:01 mr_bones_ Exp $
+
+DESCRIPTION="Yet Another Free Raytracer"
+HOMEPAGE="http://www.yafray.org"
+SRC_URI="http://www.coala.uniovi.es/~jandro/noname/downloads/${P}.tar.gz"
+
+KEYWORDS="~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="media-libs/jpeg
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s-O3 -fomit-frame-pointer -ffast-math${CXXFLAGS}" \
+ src/Makefile.am || \
+ die "sed src/Makefile.am failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS || die "dodoc failed"
+ dohtml doc/doc.html || die "dohtml failed"
+}