summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-26 19:32:19 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-26 19:32:19 +0000
commit0fc03fc26ce24efe385337e7747a944152194ab7 (patch)
treebba3b5a018244f5f24a33d18ba9e406841bf7ea4 /media-gfx
parentadd dev-lang/nasm to DEPEND (diff)
downloadhistorical-0fc03fc26ce24efe385337e7747a944152194ab7.tar.gz
historical-0fc03fc26ce24efe385337e7747a944152194ab7.tar.bz2
historical-0fc03fc26ce24efe385337e7747a944152194ab7.zip
removed PGO extensions
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/povray/ChangeLog8
-rw-r--r--media-gfx/povray/povray-3.50a.ebuild16
2 files changed, 7 insertions, 17 deletions
diff --git a/media-gfx/povray/ChangeLog b/media-gfx/povray/ChangeLog
index ca50e9223024..7a239d6ec950 100644
--- a/media-gfx/povray/ChangeLog
+++ b/media-gfx/povray/ChangeLog
@@ -1,9 +1,13 @@
-# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# ChangeLog for media-gfx/povray
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.10 2002/08/07 01:41:51 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/ChangeLog,v 1.11 2002/08/26 19:32:19 rphillips Exp $
*povray-3.5a (2 Aug 2002)
+ 26 Aug 2002; Ryan Phillips <rphillips@gentoo.org> povray-3.5a.ebuild :
+
+ Removed PGO extensions to ebuild
+
4 Aug 2002; Ryan Phillips <rphillips@gentoo.org> povray-3.5a.ebuild :
Compiles and runs now on my system. Needs testing for PPC, et al platforms
diff --git a/media-gfx/povray/povray-3.50a.ebuild b/media-gfx/povray/povray-3.50a.ebuild
index 59d978b5660f..0d3d9071ae09 100644
--- a/media-gfx/povray/povray-3.50a.ebuild
+++ b/media-gfx/povray/povray-3.50a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.50a.ebuild,v 1.5 2002/08/09 07:25:14 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/povray/povray-3.50a.ebuild,v 1.6 2002/08/26 19:32:19 rphillips Exp $
S=${WORKDIR}/${P}
DESCRIPTION="POV Ray- The Persistance of Vision Ray Tracer"
@@ -59,23 +59,9 @@ src_compile() {
#This is optimized for Pentium 4 (untested, I don't own one):
#echo "s/^CPPFLAGS =/CPPFLAGS = -O3 -xW -ip -tpp7 /" >> makefile.sed
- if [ "`use icc-pgo`" ]; then
- IPD=${BUILDDIR}/icc-pgo
- echo "s:^CPPFLAGS =:CPPFLAGS = -prof_dir ${IPD} :" >> makefile.sed
- if [ ! -d "${IPD}" ]; then
- mkdir -m 777 -p ${IPD}
- echo "s/^CPPFLAGS =/CPPFLAGS = -prof_gen /" >> makefile.sed
- einfo Building PGO prof_gen version.
- else
- einfo Building PGO prof_use version.
- echo "s/^CPPFLAGS =/CPPFLAGS = -prof_use /" >> makefile.sed
- fi
- fi
- else
# GCC CPPFLAGS
echo "s/^CPPFLAGS =/CPPFLAGS = -finline-functions -ffast-math /" >> makefile.sed
echo "s/^CPPFLAGS =/CPPFLAGS = ${CFLAGS} /" >> makefile.sed
- fi
# fix library dependency
echo 's/LIBS = \(.*\)/LIBS = \1 -ldl/' >> makefile.sed