summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-05-19 19:25:53 +0000
committerNed Ludd <solar@gentoo.org>2005-05-19 19:25:53 +0000
commitdb3a17dae043adef740475191bf41b61eb813c0e (patch)
tree51568ff64218bb2fa9ef290efaa77347e04b470d /media-libs/libdv/libdv-0.104.ebuild
parentInitial commit, ebuild written by me. Closes bug #38715. (diff)
downloadhistorical-db3a17dae043adef740475191bf41b61eb813c0e.tar.gz
historical-db3a17dae043adef740475191bf41b61eb813c0e.tar.bz2
historical-db3a17dae043adef740475191bf41b61eb813c0e.zip
- Enable --disable-asm on x86 when using pic code or the compiled libdv will contain text relocations. This should not really have to depend on when has_pic triggers or not but it's this way for now till such time as x86 more or less does a patch like the x86_64 relocation one. It may not really even matter as libdv use of asm is should only matter with the use of a RT kernel which none of us have at this point in time. Benchmarks need to be done.
Diffstat (limited to 'media-libs/libdv/libdv-0.104.ebuild')
-rw-r--r--media-libs/libdv/libdv-0.104.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/media-libs/libdv/libdv-0.104.ebuild b/media-libs/libdv/libdv-0.104.ebuild
index 7c9eeb318ff5..2dcf180c7301 100644
--- a/media-libs/libdv/libdv-0.104.ebuild
+++ b/media-libs/libdv/libdv-0.104.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdv/libdv-0.104.ebuild,v 1.3 2005/01/13 02:18:36 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdv/libdv-0.104.ebuild,v 1.4 2005/05/19 19:25:53 solar Exp $
-inherit eutils libtool
+inherit eutils libtool flag-o-matic
DESCRIPTION="Software codec for dv-format video (camcorders etc)"
HOMEPAGE="http://libdv.sourceforge.net/"
@@ -31,6 +31,7 @@ src_unpack() {
src_compile() {
econf \
+ $((use x86 && has_pic) && echo --disable-asm) \
$(use_with debug) \
$(use_enable gtk) $(use_enable gtk gtktest) \
$(use_enable sdl) \