summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2005-08-06 11:25:35 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2005-08-06 11:25:35 +0000
commit326bba2880f15f23c80310a79e84659e7f4e195e (patch)
treea0a71fe05b95fe406a1d2f9c1570a2a2b3495fd7 /media-libs/libdvb/libdvb-0.5.5.1.ebuild
parentadded scripts from bug #28940 and #28945, usage script rewritten (diff)
downloadhistorical-326bba2880f15f23c80310a79e84659e7f4e195e.tar.gz
historical-326bba2880f15f23c80310a79e84659e7f4e195e.tar.bz2
historical-326bba2880f15f23c80310a79e84659e7f4e195e.zip
Version bump (Thanks to Christoph Brill <egore@gmx.de>, bug #88163).
Removed errno-patch, it is now included in upstream. Changed dependency according to bug #98672 comment #4. Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-libs/libdvb/libdvb-0.5.5.1.ebuild')
-rw-r--r--media-libs/libdvb/libdvb-0.5.5.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-libs/libdvb/libdvb-0.5.5.1.ebuild b/media-libs/libdvb/libdvb-0.5.5.1.ebuild
new file mode 100644
index 000000000000..b48e9310daee
--- /dev/null
+++ b/media-libs/libdvb/libdvb-0.5.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvb/libdvb-0.5.5.1.ebuild,v 1.1 2005/08/06 11:25:35 zzam Exp $
+
+inherit eutils
+
+DESCRIPTION="libdvb package with added CAM library and libdvbmpegtools as well as dvb-mpegtools"
+HOMEPAGE="http://www.metzlerbros.org/dvb/"
+SRC_URI="http://www.metzlerbros.org/dvb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND=">=sys-apps/sed-4
+ || (
+ >=sys-kernel/linux-headers-2.6.11-r2
+ media-tv/linuxtv-dvb
+ )"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ # Disable compilation of sample programs
+ # and use DESTDIR when installing
+ epatch "${FILESDIR}/${P}-gentoo.patch" || die "patch failed"
+}
+
+src_compile() {
+ emake || die "compile problem"
+}
+
+src_install() {
+ #einstall DESTDIR="${D}" || die "Install problem"
+ make DESTDIR="${D}" PREFIX=/usr install || die
+
+ use doc && insinto "/usr/share/doc/${PF}/sample_progs" && \
+ doins sample_progs/* && \
+ insinto "/usr/share/doc/${PF}/samplerc" && \
+ doins samplerc/*
+
+ echo
+ einfo "The script called 'dia' has been installed as dia-dvb"
+ einfo "so that it doesn't overwrite the binary of app-office/dia."
+ einfo
+
+ dodoc README
+}