summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-27 10:42:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-27 10:42:25 +0000
commit170197749aa9b644364fe12b822258b82c18da94 (patch)
tree1319a6f4031de0e5c563b61841b865fe29edca67 /media-libs/libdvdcss/libdvdcss-1.2.13.ebuild
parentInitial commit. Ebuild & patches by Fabio Rossi in bug #356577. (diff)
downloadhistorical-170197749aa9b644364fe12b822258b82c18da94.tar.gz
historical-170197749aa9b644364fe12b822258b82c18da94.tar.bz2
historical-170197749aa9b644364fe12b822258b82c18da94.zip
Version bump; simplified ebuild, even though USE=-doc is not working properly (fixed in .14 to be released soon, and the proper fix takes more time to apply than the buggy behaviour). Remove old.
Package-Manager: portage-2.2.0_alpha163/cvs/Linux x86_64 Manifest-Sign-Key: 0x1CD13C8AD4301342
Diffstat (limited to 'media-libs/libdvdcss/libdvdcss-1.2.13.ebuild')
-rw-r--r--media-libs/libdvdcss/libdvdcss-1.2.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/libdvdcss/libdvdcss-1.2.13.ebuild b/media-libs/libdvdcss/libdvdcss-1.2.13.ebuild
new file mode 100644
index 000000000000..2afe923ead75
--- /dev/null
+++ b/media-libs/libdvdcss/libdvdcss-1.2.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdcss/libdvdcss-1.2.13.ebuild,v 1.1 2013/02/27 10:42:10 flameeyes Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A portable abstraction library for DVD decryption"
+HOMEPAGE="http://www.videolan.org/developers/libdvdcss.html"
+SRC_URI="http://www.videolan.org/pub/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+#DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc)
+ --htmldir=/usr/share/doc/${PF}/html
+ )
+
+ autotools-utils_src_configure
+}