summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-01-14 04:13:15 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-01-14 04:13:15 +0000
commit5c2b4561a8999dcbe2422a3d61ae77947adc2292 (patch)
treeb579b0b1ff403433c9bac6963aa28f3b59349025 /media-libs/libflash/libflash-0.4.10-r1.ebuild
parentrepoman: Trim trailing whitespace (diff)
downloadhistorical-5c2b4561a8999dcbe2422a3d61ae77947adc2292.tar.gz
historical-5c2b4561a8999dcbe2422a3d61ae77947adc2292.tar.bz2
historical-5c2b4561a8999dcbe2422a3d61ae77947adc2292.zip
Add patch by Stefan Vunckx <stefan.vunckx AT skynet DOT be> to fix compilation with gcc-4.1; bug #118816. Also added metadata.xml with maintainer-needed
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'media-libs/libflash/libflash-0.4.10-r1.ebuild')
-rw-r--r--media-libs/libflash/libflash-0.4.10-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-libs/libflash/libflash-0.4.10-r1.ebuild b/media-libs/libflash/libflash-0.4.10-r1.ebuild
index f58e24d1d8b6..4ec84520921a 100644
--- a/media-libs/libflash/libflash-0.4.10-r1.ebuild
+++ b/media-libs/libflash/libflash-0.4.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/libflash-0.4.10-r1.ebuild,v 1.15 2004/07/14 20:07:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libflash/libflash-0.4.10-r1.ebuild,v 1.16 2006/01/14 04:13:15 halcy0n Exp $
inherit eutils
@@ -17,15 +17,16 @@ DEPEND="media-libs/jpeg
sys-libs/zlib"
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A} ; cd "${S}"
# patch to fix the sqrt not defined problem in gcc3.1
# It should be ok with gcc2.95 thanks to Doug Goldstein
# <dougg@ufl.edu> (Cardoe)
- epatch ${FILESDIR}/${P}-sqrt.patch
+ epatch "${FILESDIR}"/${P}-sqrt.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
}
src_install() {
- make DESTDIR=${D} install || die "Install failed"
+ make DESTDIR="${D}" install || die "Install failed"
dodoc AUTHORS COPYING README
}