summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2011-12-06 02:32:55 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2011-12-06 02:32:55 +0000
commit9486160fd62b5533bc6b10aef8a1b87b98998206 (patch)
treef6438112601c6177ceca79c06809929e74918e85 /media-libs/libkface/libkface-2.4.1.ebuild
parentNew application (diff)
downloadhistorical-9486160fd62b5533bc6b10aef8a1b87b98998206.tar.gz
historical-9486160fd62b5533bc6b10aef8a1b87b98998206.tar.bz2
historical-9486160fd62b5533bc6b10aef8a1b87b98998206.zip
Version bump; remove old
Package-Manager: portage-2.1.10.39/cvs/Linux x86_64
Diffstat (limited to 'media-libs/libkface/libkface-2.4.1.ebuild')
-rw-r--r--media-libs/libkface/libkface-2.4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libkface/libkface-2.4.1.ebuild b/media-libs/libkface/libkface-2.4.1.ebuild
new file mode 100644
index 000000000000..a1ea43248f6d
--- /dev/null
+++ b/media-libs/libkface/libkface-2.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libkface/libkface-2.4.1.ebuild,v 1.1 2011/12/06 02:29:24 dilfridge Exp $
+
+EAPI=4
+
+DIGIKAMPN=digikam
+
+KDE_LINGUAS=""
+KDE_MINIMAL="4.7"
+
+CMAKE_MIN_VERSION=2.8
+
+inherit kde4-base
+
+MY_P="${DIGIKAMPN}-${PV/_/-}"
+
+DESCRIPTION="Qt/C++ wrapper around LibFace to perform face recognition and detection"
+HOMEPAGE="http://www.digikam.org/"
+SRC_URI="mirror://sourceforge/${DIGIKAMPN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SLOT=4
+
+DEPEND=">=media-libs/opencv-2.1"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}/extra/${PN}
+
+src_configure() {
+ mycmakeargs=(
+ -DFORCED_UNBUNDLE=ON
+ )
+ kde4-base_src_configure
+}