summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-02-09 18:42:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-02-09 18:42:07 +0000
commit87ffc76ae7c3001f32575443e670df691d69997d (patch)
tree5668436b64453de28dcf38eb8d1a29eedc666d72 /media-libs/mlt
parentEAPI=2; use-based deps; songs version bump (diff)
downloadhistorical-87ffc76ae7c3001f32575443e670df691d69997d.tar.gz
historical-87ffc76ae7c3001f32575443e670df691d69997d.tar.bz2
historical-87ffc76ae7c3001f32575443e670df691d69997d.zip
version bump, bug #257966
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'media-libs/mlt')
-rw-r--r--media-libs/mlt/ChangeLog7
-rw-r--r--media-libs/mlt/mlt-0.3.6.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/media-libs/mlt/ChangeLog b/media-libs/mlt/ChangeLog
index f2ba1280bcc7..63bcc382d5c5 100644
--- a/media-libs/mlt/ChangeLog
+++ b/media-libs/mlt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/mlt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.35 2009/01/30 15:02:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.36 2009/02/09 18:40:54 aballier Exp $
+
+*mlt-0.3.6 (09 Feb 2009)
+
+ 09 Feb 2009; Alexis Ballier <aballier@gentoo.org> +mlt-0.3.6.ebuild:
+ version bump, bug #257966
30 Jan 2009; Alexis Ballier <aballier@gentoo.org>
-files/mlt-0.2.2-motion-est-nonx86.patch, -files/mlt-0.3.0-sox1420.patch,
diff --git a/media-libs/mlt/mlt-0.3.6.ebuild b/media-libs/mlt/mlt-0.3.6.ebuild
new file mode 100644
index 000000000000..320fd982238e
--- /dev/null
+++ b/media-libs/mlt/mlt-0.3.6.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.3.6.ebuild,v 1.1 2009/02/09 18:40:54 aballier Exp $
+
+EAPI=1
+
+inherit eutils toolchain-funcs qt3
+
+DESCRIPTION="MLT is an open source multimedia framework, designed and developed
+for television broadcasting"
+HOMEPAGE="http://mlt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dv xml jack gtk sdl vorbis sox quicktime mmx lame xine lame ogg theora xine ffmpeg libsamplerate qt3 sse"
+
+DEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
+ dv? ( >=media-libs/libdv-0.104 )
+ xml? ( >=dev-libs/libxml2-2.5 )
+ ogg? ( >=media-libs/libogg-1.1.3 )
+ vorbis? ( >=media-libs/libvorbis-1.1.2 )
+ sdl? ( >=media-libs/libsdl-1.2.10
+ >=media-libs/sdl-image-1.2.4 )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
+ jack? ( media-sound/jack-audio-connection-kit
+ media-libs/ladspa-sdk
+ >=dev-libs/libxml2-2.5 )
+ gtk? ( >=x11-libs/gtk+-2
+ x11-libs/pango )
+ sox? ( media-sound/sox )
+ quicktime? ( media-libs/libquicktime )
+ xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
+ lame? ( >=media-sound/lame-3.97_beta2 )
+ qt3? ( x11-libs/qt:3 )
+ theora? ( >=media-libs/libtheora-1.0_alpha5 )"
+RDEPEND=${DEPEND}
+
+pkg_setup() {
+ local fail="USE sox needs also USE libsamplerate enabled."
+
+ if use sox && ! use libsamplerate; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/mlt-0.2.3-nostrip.patch
+}
+
+src_compile() {
+ tc-export CC
+
+ local myconf=" --enable-gpl --enable-shared
+ --enable-pp --enable-shared-pp
+ --enable-motion-est
+ $(use_enable dv)
+ $(use_enable mmx)
+ $(use_enable sse)
+ $(use_enable gtk gtk2)
+ $(use_enable vorbis)
+ $(use_enable ogg)
+ $(use_enable sdl)
+ $(use_enable jack jackrack)
+ $(use_enable sox)
+ $(use_enable theora)
+ $(use_enable lame mp3lame)
+ $(use_enable ffmpeg avformat)
+ $(use_enable libsamplerate resample)
+ $(use_enable qt3 qimage)
+ $(use_enable xml westley)
+ $(use_enable xine)"
+
+ use ffmpeg && has_version ">=media-video/ffmpeg-0.4.9_p20070616-r20" &&
+ myconf="${myconf} --avformat-swscale"
+
+ (use quicktime && use dv) || myconf="${myconf} --disable-kino"
+
+ econf ${myconf} || die "econf failed"
+ sed -i -e s/^OPT/#OPT/ "${S}/config.mak"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc docs/*.txt ChangeLog README docs/TODO
+
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r demo
+}