summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-28 20:41:32 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-28 20:41:32 +0000
commit1580927b7a2d5cd453b6a11a42fd1fd69337f821 (patch)
tree3d8a5e116baa5ad6b76c373eba6643a1c6feb025 /media-libs/rply/rply-1.01-r1.ebuild
parentBump EAPI to 4 (diff)
downloadhistorical-1580927b7a2d5cd453b6a11a42fd1fd69337f821.tar.gz
historical-1580927b7a2d5cd453b6a11a42fd1fd69337f821.tar.bz2
historical-1580927b7a2d5cd453b6a11a42fd1fd69337f821.zip
New ebuild, moved from gnome overlay.
Package-Manager: portage-2.2.0_alpha71/cvs/Linux x86_64
Diffstat (limited to 'media-libs/rply/rply-1.01-r1.ebuild')
-rw-r--r--media-libs/rply/rply-1.01-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/rply/rply-1.01-r1.ebuild b/media-libs/rply/rply-1.01-r1.ebuild
new file mode 100644
index 000000000000..95a475f3db78
--- /dev/null
+++ b/media-libs/rply/rply-1.01-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/rply/rply-1.01-r1.ebuild,v 1.1 2011/10/28 20:41:32 tetromino Exp $
+
+EAPI="4"
+
+inherit cmake-utils
+
+DESCRIPTION="A library to read and write PLY files"
+HOMEPAGE="http://w3.impa.br/~diego/software/rply/"
+SRC_URI="http://w3.impa.br/~diego/software/rply/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use doc && HTML_DOCS="manual/*"
+}
+
+src_prepare() {
+ # rply doesn't have *any* build system - not even a Makefile!
+ # For simplicity, use the cmake file that Fedora maintainers have created
+ cp "${FILESDIR}/rply_CMakeLists.txt" CMakeLists.txt
+ mkdir -p CMake/export
+
+ # Use int16_t and int32_t instead of assuming e.g. that sizeof(long) == 4
+ epatch "${FILESDIR}/${P}-stdint.h.patch"
+
+ # Switch LC_NUMERIC locale to "C" to ensure "." is the decimal separator
+ epatch "${FILESDIR}/${P}-lc_numeric.patch"
+}