summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:55:47 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:55:47 +0000
commit8d59ceda4fb263dbab3bf5c0e723aae6c6121017 (patch)
tree0c221e80721bcc16e2e22c54bff4ae0ede73db2a /media-plugins/mythdvd
parent2.6.x patch (diff)
downloadhistorical-8d59ceda4fb263dbab3bf5c0e723aae6c6121017.tar.gz
historical-8d59ceda4fb263dbab3bf5c0e723aae6c6121017.tar.bz2
historical-8d59ceda4fb263dbab3bf5c0e723aae6c6121017.zip
version bumps
Diffstat (limited to 'media-plugins/mythdvd')
-rw-r--r--media-plugins/mythdvd/ChangeLog7
-rw-r--r--media-plugins/mythdvd/Manifest2
-rw-r--r--media-plugins/mythdvd/files/digest-mythdvd-0.131
-rw-r--r--media-plugins/mythdvd/mythdvd-0.13.ebuild82
4 files changed, 91 insertions, 1 deletions
diff --git a/media-plugins/mythdvd/ChangeLog b/media-plugins/mythdvd/ChangeLog
index 3515383fcc9d..decc2a156ac8 100644
--- a/media-plugins/mythdvd/ChangeLog
+++ b/media-plugins/mythdvd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythdvd
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.4 2003/10/28 16:18:27 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/ChangeLog,v 1.5 2003/12/11 21:55:46 aliz Exp $
+
+*mythdvd-0.13 (11 Dec 2003)
+
+ 11 Dec 2003; Daniel Ahlberg <aliz@gentoo.org> mythdvd-0.13.ebuild:
+ Version bump.
28 Oct 2003; Max Kalika <max@gentoo.org> mythdvd-0.12.ebuild:
Extend CPU detection.
diff --git a/media-plugins/mythdvd/Manifest b/media-plugins/mythdvd/Manifest
index f147ab27a5aa..301608a8f6d6 100644
--- a/media-plugins/mythdvd/Manifest
+++ b/media-plugins/mythdvd/Manifest
@@ -1,6 +1,8 @@
MD5 00fc0fff830f25508d04a99963a988fc mythdvd-0.11.ebuild 1962
+MD5 3ea44914896929d3a547f9a964714f44 mythdvd-0.13.ebuild 2374
MD5 3ea44914896929d3a547f9a964714f44 mythdvd-0.12.ebuild 2374
MD5 86256dd7ce471b2138f11684b6f79f23 ChangeLog 661
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 29d1ec475eee7e6e4d5b6a605611c4c7 files/digest-mythdvd-0.11 64
MD5 43523be8d2e4958df76e6e1b2b63791c files/digest-mythdvd-0.12 65
+MD5 afa9416eab98d5f2ad7a39bc35be2561 files/digest-mythdvd-0.13 65
diff --git a/media-plugins/mythdvd/files/digest-mythdvd-0.13 b/media-plugins/mythdvd/files/digest-mythdvd-0.13
new file mode 100644
index 000000000000..413e6b5d3779
--- /dev/null
+++ b/media-plugins/mythdvd/files/digest-mythdvd-0.13
@@ -0,0 +1 @@
+MD5 c835938627ad1ce5124cc33e24539e28 mythdvd-0.13.tar.bz2 116060
diff --git a/media-plugins/mythdvd/mythdvd-0.13.ebuild b/media-plugins/mythdvd/mythdvd-0.13.ebuild
new file mode 100644
index 000000000000..7f705afadde5
--- /dev/null
+++ b/media-plugins/mythdvd/mythdvd-0.13.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythdvd/mythdvd-0.13.ebuild,v 1.1 2003/12/11 21:55:46 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="DVD player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="alsa lirc transcode"
+
+DEPEND="media-libs/libdvdread
+ >=sys-apps/sed-4
+ >=media-plugins/mythvideo-${PV}
+ transcode? ( media-video/transcode )
+ || ( media-video/mplayer media-video/xine-ui media-video/ogle )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local myconf="--enable-vcd"
+ myconf="${myconf} `use_enable transcode`"
+
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ if [ "`use alsa`" ] ; then
+ echo "CONFIG += using_alsa" >> settings.pro
+ echo "EXTRA_LIBS += -lasound" >> settings.pro
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#EXTRA_LIBS += -llirc_client:EXTRA_LIBS += -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+
+ econf ${myconf}
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins dvddb/*.sql
+
+ dodoc AUTHORS COPYING README UPGRADING
+ newdoc dvddb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythDVD,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/README.db.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}