summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2008-03-24 09:55:01 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2008-03-24 09:55:01 +0000
commit601f3ba49984e68614d510b75f2e922be70e8004 (patch)
tree9c032dedc4cb762abd74105c764c0782113c7dae /media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild
parentversion bump (diff)
downloadhistorical-601f3ba49984e68614d510b75f2e922be70e8004.tar.gz
historical-601f3ba49984e68614d510b75f2e922be70e8004.tar.bz2
historical-601f3ba49984e68614d510b75f2e922be70e8004.zip
initial ebuild, moved from overlay vdr-1.5
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild')
-rw-r--r--media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild b/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild
new file mode 100644
index 000000000000..54c09c4c0215
--- /dev/null
+++ b/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-atscepg/vdr-atscepg-0.1.1.ebuild,v 1.1 2008/03/24 09:55:01 hd_brummy Exp $
+
+inherit vdr-plugin
+
+DESCRIPTION="VDR plugin: implements the Program and System Information
+Protocol for DVB-T and DVB-C Broadcast from the ATSC standard"
+HOMEPAGE="http://www.fepg.org/atscepg.html"
+SRC_URI="http://www.fepg.org/files/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6"
+
+pkg_setup() {
+
+ if ! built_with_use media-video/vdr atsc; then
+ echo
+ ewarn "To support this plugin you need to"
+ ewarn "recompile media-video/vdr with use-flag atsc"
+ echo
+ fi
+}
+
+src_unpack() {
+ vdr-plugin_src_unpack
+
+ fix_vdr_libsi_include tables.cpp
+}