summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-05-15 22:04:04 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-05-15 22:04:04 +0000
commit638482d0c2cdca74c3729e7b16a05499ea0fbc50 (patch)
tree0ce8682d3a27da1b56dcc265a4e9db666dfec1cc /media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
parentInitial commit (diff)
downloadhistorical-638482d0c2cdca74c3729e7b16a05499ea0fbc50.tar.gz
historical-638482d0c2cdca74c3729e7b16a05499ea0fbc50.tar.bz2
historical-638482d0c2cdca74c3729e7b16a05499ea0fbc50.zip
cleanup
Diffstat (limited to 'media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild')
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
deleted file mode 100644
index 69794aebea4a..000000000000
--- a/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild,v 1.11 2003/02/13 13:05:24 vapier Exp $
-
-DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
-HOMEPAGE="http://www.alsa-project.org/"
-
-# By default, drivers for all supported cards will be compiled.
-# If you want to only compile for specific card(s), set ALSA_CARDS
-# environment variable accordingly
-[ x${ALSA_CARDS} = x ] && ALSA_CARDS=all
-
-SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}.tar.bz2"
-S=${WORKDIR}/${P/_rc/rc}
-
-# Need the baselayout 1.7.9 or newer for the init script to work correctly.
-DEPEND="sys-devel/autoconf
- virtual/glibc
- >=sys-apps/portage-1.9.10
- >=sys-apps/baselayout-1.7.9"
-PROVIDE="virtual/alsa"
-
-SLOT="0.9"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="x86 ppc"
-
-src_unpack() {
- # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
- # instead of /etc/init.d. However, this causes alsa's installer
- # to do the same foolish thing. This *hack* inibits the problem.
- # I filed a bug report about this with the ALSA people:
- # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
- unpack ${A}
- cd ${S}
- sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
- mv Makefile.hacked Makefile
- if [ ${ARCH} = "ppc" ]
- then patch -p1 < ${FILESDIR}/alsa-driver-0.9.0rc1-ppc.patch || die
- fi
-}
-
-
-src_compile() {
- # Portage should determine the version of the kernel sources
- check_KV
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --with-kernel="${ROOT}usr/src/linux" \
- --with-isapnp=yes \
- --with-sequencer=yes \
- --with-oss=yes \
- --with-cards=${ALSA_CARDS} \
- || die "./configure failed"
-
- emake || die "Parallel Make Failed"
-}
-
-
-src_install () {
- dodir /usr/include/sound
- dodir /etc/init.d
- make DESTDIR=${D} install || die
-
- dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
-
- insinto /etc/modules.d
- newins ${FILESDIR}/alsa-modules.conf alsa
- exeinto /etc/init.d
- doexe ${FILESDIR}/alsasound
-}
-
-pkg_postinst () {
- if [ "${ROOT}" = / ]
- then
- [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
- fi
-
- einfo
- einfo "You might want to edit file /etc/modules.d/alsa according to your"
- einfo "hardware configuration."
- einfo
- einfo "If you are going to be using the 'alsasound' init script, make sure"
- einfo "that you add it to the 'boot' runlevel (not 'default')."
- einfo
-}