summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-02 09:07:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-02 09:07:24 +0000
commitf9f06ace4eee2613960cc2ea6f73a9c34dd7698c (patch)
tree23028bc55bd20a27cea85950d99cbdf541a40fff /media-sound/alsa-driver/files
parentCleanup old verisons. (diff)
downloadhistorical-f9f06ace4eee2613960cc2ea6f73a9c34dd7698c.tar.gz
historical-f9f06ace4eee2613960cc2ea6f73a9c34dd7698c.tar.bz2
historical-f9f06ace4eee2613960cc2ea6f73a9c34dd7698c.zip
Cleanup old verisons.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'media-sound/alsa-driver/files')
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-0.9.8-au-fix.patch24
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch105
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.101
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.10-r11
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc31
-rw-r--r--media-sound/alsa-driver/files/makefile.patch28
6 files changed, 0 insertions, 160 deletions
diff --git a/media-sound/alsa-driver/files/alsa-driver-0.9.8-au-fix.patch b/media-sound/alsa-driver/files/alsa-driver-0.9.8-au-fix.patch
deleted file mode 100644
index daeba268271a..000000000000
--- a/media-sound/alsa-driver/files/alsa-driver-0.9.8-au-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur alsa-driver-0.9.8.orig/alsa-kernel/drivers/mpu401/Makefile alsa-driver-0.9.8/alsa-kernel/drivers/mpu401/Makefile
---- alsa-driver-0.9.8.orig/alsa-kernel/drivers/mpu401/Makefile 2003-06-02 05:59:40.000000000 -0700
-+++ alsa-driver-0.9.8/alsa-kernel/drivers/mpu401/Makefile 2004-02-08 01:18:47.000000000 -0800
-@@ -41,5 +41,8 @@
- obj-$(CONFIG_SND_YMFPCI) += snd-mpu401-uart.o
- obj-$(CONFIG_SND_PC98_CS4232) += snd-mpu401-uart.o
- obj-$(CONFIG_SND_SSCAPE) += snd-mpu401-uart.o
-+obj-$(CONFIG_SND_AU8810) += snd-mpu401-uart.o
-+obj-$(CONFIG_SND_AU8820) += snd-mpu401-uart.o
-+obj-$(CONFIG_SND_AU8830) += snd-mpu401-uart.o
-
- obj-m := $(sort $(obj-m))
-diff -Naur alsa-driver-0.9.8.orig/alsa-kernel/pci/ac97/Makefile alsa-driver-0.9.8/alsa-kernel/pci/ac97/Makefile
---- alsa-driver-0.9.8.orig/alsa-kernel/pci/ac97/Makefile 2003-06-17 11:43:31.000000000 -0700
-+++ alsa-driver-0.9.8/alsa-kernel/pci/ac97/Makefile 2004-02-08 01:17:58.000000000 -0800
-@@ -23,5 +23,8 @@
- obj-$(CONFIG_SND_NM256) += snd-ac97-codec.o
- obj-$(CONFIG_SND_TRIDENT) += snd-ac97-codec.o
- obj-$(CONFIG_SND_YMFPCI) += snd-ac97-codec.o
-+obj-$(CONFIG_SND_AU8810) += snd-ac97-codec.o
-+obj-$(CONFIG_SND_AU8820) += snd-ac97-codec.o
-+obj-$(CONFIG_SND_AU8830) += snd-ac97-codec.o
-
- obj-m := $(sort $(obj-m))
diff --git a/media-sound/alsa-driver/files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch b/media-sound/alsa-driver/files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch
deleted file mode 100644
index 43a462a004eb..000000000000
--- a/media-sound/alsa-driver/files/alsa-driver-1.0.10_rc3-ppc-unbreakage.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-Index: alsa-driver-1.0.10rc3/sound/ppc/beep.c
-===================================================================
---- alsa-driver-1.0.10rc3.orig/sound/ppc/beep.c
-+++ alsa-driver-1.0.10rc3/sound/ppc/beep.c
-@@ -31,14 +31,14 @@
- #include "pmac.h"
-
- struct snd_pmac_beep {
-- int running; /* boolean */
-- int volume; /* mixer volume: 0-100 */
-+ int running; /* boolean */
-+ int volume; /* mixer volume: 0-100 */
- int volume_play; /* currently playing volume */
- int hz;
- int nsamples;
- short *buf; /* allocated wave buffer */
- dma_addr_t addr; /* physical address of buffer */
-- struct input_dev *dev;
-+ struct input_dev dev;
- };
-
- /*
-@@ -210,55 +210,47 @@ static snd_kcontrol_new_t snd_pmac_beep_
- int __init snd_pmac_attach_beep(pmac_t *chip)
- {
- pmac_beep_t *beep;
-- struct input_dev *input_dev;
-- void *dmabuf;
-- int err = -ENOMEM;
--
-- beep = kzalloc(sizeof(*beep), GFP_KERNEL);
-- dmabuf = dma_alloc_coherent(&chip->pdev->dev, BEEP_BUFLEN * 4,
-- &beep->addr, GFP_KERNEL);
-- input_dev = input_allocate_device();
-- if (!beep || !dmabuf || !input_dev)
-- goto fail;
-+ int err;
-+
-+ beep = kmalloc(sizeof(*beep), GFP_KERNEL);
-+ if (! beep)
-+ return -ENOMEM;
-+
-+ memset(beep, 0, sizeof(*beep));
-+ beep->buf = dma_alloc_coherent(&chip->pdev->dev, BEEP_BUFLEN * 4,
-+ &beep->addr, GFP_KERNEL);
-+
-+ beep->dev.evbit[0] = BIT(EV_SND);
-+ beep->dev.sndbit[0] = BIT(SND_BELL) | BIT(SND_TONE);
-+ beep->dev.event = snd_pmac_beep_event;
-+ beep->dev.private = chip;
-
- /* FIXME: set more better values */
-- input_dev->name = "PowerMac Beep";
-- input_dev->phys = "powermac/beep";
-- input_dev->id.bustype = BUS_ADB;
-- input_dev->id.vendor = 0x001f;
-- input_dev->id.product = 0x0001;
-- input_dev->id.version = 0x0100;
--
-- input_dev->evbit[0] = BIT(EV_SND);
-- input_dev->sndbit[0] = BIT(SND_BELL) | BIT(SND_TONE);
-- input_dev->event = snd_pmac_beep_event;
-- input_dev->private = chip;
-- input_dev->cdev.dev = &chip->pdev->dev;
-+ beep->dev.name = "PowerMac Beep";
-+ beep->dev.phys = "powermac/beep";
-+ beep->dev.id.bustype = BUS_ADB;
-+ beep->dev.id.vendor = 0x001f;
-+ beep->dev.id.product = 0x0001;
-+ beep->dev.id.version = 0x0100;
-
-- beep->dev = input_dev;
-- beep->buf = dmabuf;
- beep->volume = BEEP_VOLUME;
- beep->running = 0;
--
-- err = snd_ctl_add(chip->card, snd_ctl_new1(&snd_pmac_beep_mixer, chip));
-- if (err < 0)
-- goto fail;
-+ if ((err = snd_ctl_add(chip->card, snd_ctl_new1(&snd_pmac_beep_mixer, chip))) < 0) {
-+ kfree(beep->buf);
-+ kfree(beep);
-+ return err;
-+ }
-
- chip->beep = beep;
-- input_register_device(beep->dev);
-+ input_register_device(&beep->dev);
-
- return 0;
--
-- fail: input_free_device(input_dev);
-- kfree(dmabuf);
-- kfree(beep);
-- return err;
- }
-
- void snd_pmac_detach_beep(pmac_t *chip)
- {
- if (chip->beep) {
-- input_unregister_device(chip->beep->dev);
-+ input_unregister_device(&chip->beep->dev);
- dma_free_coherent(&chip->pdev->dev, BEEP_BUFLEN * 4,
- chip->beep->buf, chip->beep->addr);
- kfree(chip->beep);
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10
deleted file mode 100644
index 5d0bc883e3c8..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e9e7c1ca664a14275d67185049f933f9 alsa-driver-1.0.10.tar.bz2 2194644
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10-r1 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10-r1
deleted file mode 100644
index 5d0bc883e3c8..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e9e7c1ca664a14275d67185049f933f9 alsa-driver-1.0.10.tar.bz2 2194644
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc3 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc3
deleted file mode 100644
index b87b0b3a9b6a..000000000000
--- a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.10_rc3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4a5bae151a08cc0d6a6a768bf4a7207e alsa-driver-1.0.10rc3.tar.bz2 2191881
diff --git a/media-sound/alsa-driver/files/makefile.patch b/media-sound/alsa-driver/files/makefile.patch
deleted file mode 100644
index 8190cb78ea77..000000000000
--- a/media-sound/alsa-driver/files/makefile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.hacked 2003-05-23 11:24:05.000000000 +0100
-+++ Makefile 2003-08-05 21:19:05.809762711 +0100
-@@ -107,7 +107,7 @@
- mv -f snd.map1 snd.map
-
- .PHONY: install
--install: install-modules install-headers install-scripts check-snd-prefix
-+install: install-modules install-headers check-snd-prefix
- @if [ -L /dev/snd ]; then \
- echo "The ALSA devices were removed from /proc/asound/dev directory." ; \
- echo "Creating static device entries in /dev/snd." ; \
-@@ -146,16 +146,6 @@
- -/sbin/depmod -a -b $(DESTDIR)/ $(SYSTEM_MAP_OPT) $(kaversion)
- endif
-
--.PHONY: install-scripts
--install-scripts:
-- if [ -d $(DESTDIR)/sbin/init.d ]; then \
-- install -m 755 -g $(IGROUP) -o $(IUSER) utils/alsasound $(DESTDIR)/sbin/init.d/alsasound; \
-- elif [ -d $(DESTDIR)/etc/rc.d/init.d ]; then \
-- install -m 755 -g $(IGROUP) -o $(IUSER) utils/alsasound $(DESTDIR)/etc/rc.d/init.d/alsasound; \
-- elif [ -d $(DESTDIR)/etc/init.d ]; then \
-- install -m 755 -g $(IGROUP) -o $(IUSER) utils/alsasound $(DESTDIR)/etc/init.d/alsasound; \
-- fi
--
- .PHONY: check-snd-prefix
- check-snd-prefix:
- @ if [ x"$(DESTDIR)" = x ]; then \