summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2006-10-24 21:15:13 +0000
committerTony Vroon <chainsaw@gentoo.org>2006-10-24 21:15:13 +0000
commitcdbecfe37b8e43a34cbd5ab56704825528deb2d6 (patch)
treeb4bc092e310f18a61089e0d5d1232028ce5beb71 /media-sound/audacious/audacious-1.2.1.ebuild
parentAdded quake3-ra3 to the games-mods quake3 mask. (diff)
downloadhistorical-cdbecfe37b8e43a34cbd5ab56704825528deb2d6.tar.gz
historical-cdbecfe37b8e43a34cbd5ab56704825528deb2d6.tar.bz2
historical-cdbecfe37b8e43a34cbd5ab56704825528deb2d6.zip
And let nobody say that audacious upstream is slow. The "KDE OMG memleak" from bug #152001 has been resolved. We even bumped the release number for you!
Package-Manager: portage-2.1.2_pre3-r7
Diffstat (limited to 'media-sound/audacious/audacious-1.2.1.ebuild')
-rw-r--r--media-sound/audacious/audacious-1.2.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/audacious/audacious-1.2.1.ebuild b/media-sound/audacious/audacious-1.2.1.ebuild
new file mode 100644
index 000000000000..3ed2f3cdbf9d
--- /dev/null
+++ b/media-sound/audacious/audacious-1.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.2.1.ebuild,v 1.1 2006/10/24 21:15:13 chainsaw Exp $
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="chardet nls gnome"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.1
+ dev-libs/libxml2
+ gnome? ( >=gnome-base/gconf-2.6.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.2.2"
+
+src_compile() {
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable gnome gconf) \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}