summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-02 07:18:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-02 07:18:22 +0000
commita6894d1c5e0fc45a71e3d4dfcf006a2034de55f9 (patch)
tree73651ed3b1a4d06100f3610cb762bddc5925e094 /media-sound/mad
parentzapping old gentoo-web ebuild (diff)
downloadhistorical-a6894d1c5e0fc45a71e3d4dfcf006a2034de55f9.tar.gz
historical-a6894d1c5e0fc45a71e3d4dfcf006a2034de55f9.tar.bz2
historical-a6894d1c5e0fc45a71e3d4dfcf006a2034de55f9.zip
add pkg config details
Diffstat (limited to 'media-sound/mad')
-rw-r--r--media-sound/mad/ChangeLog14
-rw-r--r--media-sound/mad/files/digest-mad-0.14.2b-r21
-rw-r--r--media-sound/mad/files/id3tag.pc11
-rw-r--r--media-sound/mad/files/mad.pc11
-rw-r--r--media-sound/mad/mad-0.14.2b-r2.ebuild38
5 files changed, 72 insertions, 3 deletions
diff --git a/media-sound/mad/ChangeLog b/media-sound/mad/ChangeLog
index 58c155a53f73..8fc65a68dca3 100644
--- a/media-sound/mad/ChangeLog
+++ b/media-sound/mad/ChangeLog
@@ -1,10 +1,18 @@
# ChangeLog for media-sound/mad
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mad/ChangeLog,v 1.4 2002/09/14 03:12:44 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mad/ChangeLog,v 1.5 2002/12/02 07:18:22 seemant Exp $
-*mad-0.14.2b-r2 (7 July 2002)
+*mad-0.14.2b-r2 (01 Dec 2002)
- 13 Sep 2002; Donny Davies <woodchip@gentoo.org> mad-0.14.2b-r2.ebuild :
+ 01 Dec 2002; Seemant Kulleen <seemant@gentoo.org> mad-0.14.2b-r2.ebuild
+ files/mad.pc files/id3tag.pc files/digest-mad-0.14.2b-r2 :
+
+ added id3tag.pc and mad.pc needed by xmms-mad-0.5.1.ebuild. Thanks to:
+ spam@matzsoft.de (Mathias Menzel-Nielsen) in bug #11454
+
+*mad-0.14.2b-r1 (7 July 2002)
+
+ 13 Sep 2002; Donny Davies <woodchip@gentoo.org> mad-0.14.2b-r1.ebuild :
sys-devel/ld.so is deprecated; #6476.
7 Jul 2002; Mark Guertin <gerk@gentoo.org> Changelog :
diff --git a/media-sound/mad/files/digest-mad-0.14.2b-r2 b/media-sound/mad/files/digest-mad-0.14.2b-r2
new file mode 100644
index 000000000000..4d4bba1ea629
--- /dev/null
+++ b/media-sound/mad/files/digest-mad-0.14.2b-r2
@@ -0,0 +1 @@
+MD5 eb3bfbe634ba9d5b4928aa11e0f6819d mad-0.14.2b.tar.gz 721345
diff --git a/media-sound/mad/files/id3tag.pc b/media-sound/mad/files/id3tag.pc
new file mode 100644
index 000000000000..89fde3efcb26
--- /dev/null
+++ b/media-sound/mad/files/id3tag.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: id3tag
+Description: ID3 tag reading library
+Requires:
+Version: 0.14.2b
+Libs: -L${libdir} -lid3tag -lz
+Cflags: -L${includedir}
diff --git a/media-sound/mad/files/mad.pc b/media-sound/mad/files/mad.pc
new file mode 100644
index 000000000000..f8e622f0fe6b
--- /dev/null
+++ b/media-sound/mad/files/mad.pc
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: mad
+Description: MPEG Audio Decoder
+Requires:
+Version: 0.14.2b
+Libs: -L${libdir} -lmad -lm
+Cflags: -I${includedir}
diff --git a/media-sound/mad/mad-0.14.2b-r2.ebuild b/media-sound/mad/mad-0.14.2b-r2.ebuild
new file mode 100644
index 000000000000..80888e18fde0
--- /dev/null
+++ b/media-sound/mad/mad-0.14.2b-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mad/mad-0.14.2b-r2.ebuild,v 1.3 2002/12/02 07:18:22 seemant Exp $
+
+IUSE="nls esd"
+
+S=${WORKDIR}/${P}
+HOMEPAGE="http://mad.sourceforge.net/"
+DESCRIPTION="A high-quality MP3 decoder"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+DEPEND="esd? ( media-sound/esound )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use esd || myconf="${myconf} --without-esd"
+ use nls || myconf="${myconf} --disable-nls"
+ econf \
+ --enable-static \
+ --enable-shared \
+ ${myconf}
+ emake || make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPY* CREDITS README TODO VERSION
+ #add id3tag.pc
+ insinto /usr/lib/pkgconfig/
+ doins ${FILESDIR}/id3tag.pc
+ # and mad.pc
+ doins ${FILESDIR}/mad.pc
+}