summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-12 08:04:38 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-12 08:04:38 +0000
commitf486030a7bb85d7a16300a3f51f5915ca0b85db6 (patch)
tree61b4914a4f085f54ec9544881bd3048a8c3b60d0 /media-sound/mpg321
parentmacos keyword (diff)
downloadhistorical-f486030a7bb85d7a16300a3f51f5915ca0b85db6.tar.gz
historical-f486030a7bb85d7a16300a3f51f5915ca0b85db6.tar.bz2
historical-f486030a7bb85d7a16300a3f51f5915ca0b85db6.zip
Make ebuild play nicer with GRP.
Diffstat (limited to 'media-sound/mpg321')
-rw-r--r--media-sound/mpg321/ChangeLog5
-rw-r--r--media-sound/mpg321/Manifest6
-rw-r--r--media-sound/mpg321/mpg321-0.2.10-r1.ebuild47
3 files changed, 24 insertions, 34 deletions
diff --git a/media-sound/mpg321/ChangeLog b/media-sound/mpg321/ChangeLog
index fe308577be3d..34d4c22252a2 100644
--- a/media-sound/mpg321/ChangeLog
+++ b/media-sound/mpg321/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/mpg321
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/ChangeLog,v 1.17 2004/06/25 00:13:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/ChangeLog,v 1.18 2004/07/12 08:04:38 eradicator Exp $
+
+ 12 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> :
+ Make ebuild play nicer with GRP.
03 May 2004; Jeremy Huddleston <eradicator@gentoo.org>
mpg321-0.2.10-r1.ebuild:
diff --git a/media-sound/mpg321/Manifest b/media-sound/mpg321/Manifest
index 84f68803b83e..787145a8373f 100644
--- a/media-sound/mpg321/Manifest
+++ b/media-sound/mpg321/Manifest
@@ -1,5 +1,5 @@
-MD5 fa42ad06ae819a8ea869f24cd9e5df52 ChangeLog 2516
-MD5 f2d11f78233de7aff97f453716dfc3c8 mpg321-0.2.10-r1.ebuild 1250
+MD5 aef1d5854ed0bbf76c73c9c51c55cfff ChangeLog 2613
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 f69e111b891dc01d56fb394621897e0d files/mpg321-0.1.5-ao.diff 7909
+MD5 c9213c2b82b80014b88c0322d75746e5 mpg321-0.2.10-r1.ebuild 1209
MD5 7f4e867ab9a86c4f3618228fdccc48f4 files/digest-mpg321-0.2.10-r1 65
+MD5 f69e111b891dc01d56fb394621897e0d files/mpg321-0.1.5-ao.diff 7909
diff --git a/media-sound/mpg321/mpg321-0.2.10-r1.ebuild b/media-sound/mpg321/mpg321-0.2.10-r1.ebuild
index 99a108297f1e..cffe9779e987 100644
--- a/media-sound/mpg321/mpg321-0.2.10-r1.ebuild
+++ b/media-sound/mpg321/mpg321-0.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.10-r1.ebuild,v 1.19 2004/06/25 00:13:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.10-r1.ebuild,v 1.20 2004/07/12 08:04:38 eradicator Exp $
IUSE=""
@@ -17,36 +17,9 @@ KEYWORDS="amd64 x86 ~ppc sparc mips alpha"
PROVIDE="virtual/mpg123"
-MPG123="false"
-
-pkg_setup() {
-
- # test if mpg123 owns the /usr/bin/mpg123 file. If it does, then do not
- # create a symlink. If it is already a symlink or does not exist, then
- # we create it
- if [ -f /usr/bin/mpg123 ]
- then
- if [ -L /usr/bin/mpg123 ]
- then
- MPEG123="false"
- else
- MPEG123="true"
- fi
- else
- MPEG123="false"
- fi
-}
-
src_compile() {
- local myconf
- if [ ${MPEG123} = "true" ]
- then
- myconf="--disable-mpg123-symlink"
- else
- myconf="--enable-mpg123-symlink"
- fi
- einfo ${myconf}
- econf ${myconf} || die
+ # disabling the symlink here and doing it in postinst is better for GRP
+ econf --disable-mpg123-symlink || die
emake || die
}
@@ -54,3 +27,17 @@ src_install () {
make DESTDIR=${D} install || die
dodoc AUTHORS BUGS COPYING ChangeLog HACKING INSTALL NEWS README README.remote THANKS TODO
}
+
+pkg_postinst() {
+ # We create a symlink for /usr/bin/mpg123 if it doesn't already exist
+ if ! [ -f /usr/bin/mpg123 ]; then
+ ln -s mpg321 /usr/bin/mpg123
+ fi
+}
+
+pkg_postrm() {
+ # We can't delete it here because it would break upgrades.
+ if [ -L /usr/bin/mpg123 ]; then
+ einfo "The /usr/bin/mpg123 symlink still exists. You may wish to remove it."
+ fi
+}