summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-15 21:24:56 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-15 21:24:56 +0000
commita9442641155499bac6d510ff4afd8ace9e105d0b (patch)
tree92c1bd5a8c017355f522e2f286d70622eaf4ebab /media-sound/sox
parent*** empty log message *** (diff)
downloadhistorical-a9442641155499bac6d510ff4afd8ace9e105d0b.tar.gz
historical-a9442641155499bac6d510ff4afd8ace9e105d0b.tar.bz2
historical-a9442641155499bac6d510ff4afd8ace9e105d0b.zip
*** empty log message ***
Diffstat (limited to 'media-sound/sox')
-rw-r--r--media-sound/sox/files/digest1
-rw-r--r--media-sound/sox/sox-12.16.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/sox/files/digest b/media-sound/sox/files/digest
new file mode 100644
index 000000000000..900c9d4c5ca6
--- /dev/null
+++ b/media-sound/sox/files/digest
@@ -0,0 +1 @@
+MD5 704e897a71213565c3c46cc17176b247 sox-12.16.tar.gz
diff --git a/media-sound/sox/sox-12.16.ebuild b/media-sound/sox/sox-12.16.ebuild
new file mode 100644
index 000000000000..f4b38763bb02
--- /dev/null
+++ b/media-sound/sox/sox-12.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-12.16.ebuild,v 1.1 2000/08/15 21:24:56 achim Exp $
+
+P=sox-12.16
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="media-sound"
+DESCRIPTION="The swiss army knife of sound processing programs"
+SRC_URI="http://metalab.unc.edu/pub/Linux/apps/sound/convert/${A}"
+HOMEPAGE="http://home.sprynet.com/~cgabwell/sox.html"
+
+
+src_compile() {
+
+ cd ${S}
+ ./configure --prefix=/usr --host=${CHOST} \
+ --enable-fast-ulaw --enable-fast-alaw
+ make
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin sox
+ doman sox.1
+ dodoc CHEAT README sox.txt TIPS TODO
+
+}
+
+