summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-24 12:28:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-24 12:28:13 +0000
commit24d91ea8bf1e6af6c328d3eaa0e9af0a4741c40c (patch)
tree42c3c52d07eef6c6a825e159b12bce6f90f4c7a4 /media-sound/waif
parentFix for gnome-panel to not overwrite 2.2 screenshoter (diff)
downloadhistorical-24d91ea8bf1e6af6c328d3eaa0e9af0a4741c40c.tar.gz
historical-24d91ea8bf1e6af6c328d3eaa0e9af0a4741c40c.tar.bz2
historical-24d91ea8bf1e6af6c328d3eaa0e9af0a4741c40c.zip
version bump
Diffstat (limited to 'media-sound/waif')
-rw-r--r--media-sound/waif/ChangeLog8
-rw-r--r--media-sound/waif/files/digest-waif-0.59.52
-rw-r--r--media-sound/waif/waif-0.59.5.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/media-sound/waif/ChangeLog b/media-sound/waif/ChangeLog
index 1d619828d4c4..b0819879eb61 100644
--- a/media-sound/waif/ChangeLog
+++ b/media-sound/waif/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/waif
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/waif/ChangeLog,v 1.5 2003/02/09 22:31:43 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/waif/ChangeLog,v 1.6 2003/02/24 12:28:13 seemant Exp $
+
+*waif-0.59.5 (24 Feb 2003)
+
+ 24 Feb 2003; Seemant Kulleen <seemant@gentoo.org> waif-0.59.5.ebuild files/digest-waif-0.59.5 :
+ version bump thanks to Matthew Levine via e-mail. New release contains bugfixes
+ and allows for trplayer to play rtsp:// streams.
*waif-0.59.4 (08 Feb 2003)
diff --git a/media-sound/waif/files/digest-waif-0.59.5 b/media-sound/waif/files/digest-waif-0.59.5
new file mode 100644
index 000000000000..774a46bd7b03
--- /dev/null
+++ b/media-sound/waif/files/digest-waif-0.59.5
@@ -0,0 +1,2 @@
+MD5 a3950e3a63163caa39f2723062fdff87 waif-0.59.5.tar.gz 61101
+MD5 563a36a809ff3e422f41ed5cc90c8a69 wfxmms-0.6.tgz 5192
diff --git a/media-sound/waif/waif-0.59.5.ebuild b/media-sound/waif/waif-0.59.5.ebuild
new file mode 100644
index 000000000000..2ee090a1461a
--- /dev/null
+++ b/media-sound/waif/waif-0.59.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/waif/waif-0.59.5.ebuild,v 1.1 2003/02/24 12:28:13 seemant Exp $
+
+IUSE="X gnome"
+
+S=${WORKDIR}/${PN}
+S2=${WORKDIR}/wfxmms
+DESCRIPTION="Why Another Infernal Frontend -- console front end for various media-players"
+HOMEPAGE="http://eds.org/~straycat"
+SRC_URI="http://www.eds.org/~straycat/${P}.tar.gz
+ xmms? http://www.eds.org/~straycat/wfxmms-0.6.tgz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND="dev-lang/tcl
+ dev-tcltk/expect"
+
+RDEPEND="dev-tcltk/expect
+ media-sound/takcd
+ media-sound/aumix
+ media-sound/id3ed
+ xmms? ( media-sound/xmms )
+ oggvorbis? ( media-sound/vorbis-tools )"
+
+
+src_compile() {
+ cd Waif
+ ./mkindex.sh || die
+
+ if use xmms
+ then
+ cd ${S2}
+ make || die
+ fi
+}
+
+src_install() {
+
+ local tclv
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's:^.*"\(.*\)".*:\1:')
+
+ cd ${S}
+ insinto /usr/lib/tcl${tclv}/Waif
+ doins Waif/*
+
+ into /usr
+ dobin waif-helper waifsh
+ doman waifsh.1
+
+ dodoc CHANGES FAQ INSTALL README* TODO WHATSNEW
+ dodoc ${FILESDIR}/LICENSE
+ docinto Documentation
+ dodoc Documentation/*
+
+ if use xmms
+ then
+ cd ${S2}
+ into /usr
+ dobin wfxmms
+
+ docinto wfxmms
+ dodoc BUGS CHANGES README
+ fi
+}