summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-09-29 05:58:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-09-29 05:58:47 +0000
commit2ffc2a6fb977396f97803997421c888bfbc6b614 (patch)
tree6256314b48a4ad4c1f57b4e472b7e728701f2b03 /media-sound
parentAdd a new revision using EAPI=2 and USE dependencies. (diff)
downloadhistorical-2ffc2a6fb977396f97803997421c888bfbc6b614.tar.gz
historical-2ffc2a6fb977396f97803997421c888bfbc6b614.tar.bz2
historical-2ffc2a6fb977396f97803997421c888bfbc6b614.zip
Add a new revision using EAPI=2 and USE dependencies.
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ecasound/ChangeLog8
-rw-r--r--media-sound/ecasound/ecasound-2.5.2-r1.ebuild88
-rw-r--r--media-sound/fluidsynth/ChangeLog8
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild65
4 files changed, 167 insertions, 2 deletions
diff --git a/media-sound/ecasound/ChangeLog b/media-sound/ecasound/ChangeLog
index 1a9bf40c2a57..d9c539749c4b 100644
--- a/media-sound/ecasound/ChangeLog
+++ b/media-sound/ecasound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ecasound
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.47 2008/08/29 07:30:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ChangeLog,v 1.48 2008/09/29 05:55:27 flameeyes Exp $
+
+*ecasound-2.5.2-r1 (29 Sep 2008)
+
+ 29 Sep 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +ecasound-2.5.2-r1.ebuild:
+ Add a new revision using EAPI=2 and USE dependencies.
*ecasound-2.5.2 (29 Aug 2008)
diff --git a/media-sound/ecasound/ecasound-2.5.2-r1.ebuild b/media-sound/ecasound/ecasound-2.5.2-r1.ebuild
new file mode 100644
index 000000000000..ad3a3fea9925
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.5.2-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.5.2-r1.ebuild,v 1.1 2008/09/29 05:55:27 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils multilib python
+
+DESCRIPTION="a package for multitrack audio processing"
+HOMEPAGE="http://ecasound.seul.org/ecasound"
+SRC_URI="http://${PN}.seul.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa arts audiofile debug doc jack libsamplerate mikmod ncurses vorbis oss python ruby sndfile"
+
+DEPEND="python? ( dev-lang/python )
+ jack? ( media-sound/jack-audio-connection-kit )
+ media-libs/ladspa-sdk
+ audiofile? ( media-libs/audiofile )
+ alsa? ( media-libs/alsa-lib[midi] )
+ vorbis? ( media-libs/libvorbis )
+ arts? ( kde-base/arts )
+ libsamplerate? ( media-libs/libsamplerate )
+ mikmod? ( media-libs/libmikmod )
+ ruby? ( dev-lang/ruby )
+ python? ( dev-lang/python )
+ ncurses? ( sys-libs/ncurses )
+ sndfile? ( media-libs/libsndfile )
+ sys-libs/readline"
+
+src_compile() {
+ local PYConf
+
+ if use python; then
+ python_version
+ PYConf="--enable-pyecasound=c
+ --with-python-includes=/usr/include/python${PYVER}
+ --with-python-modules=/usr/$(get_libdir)/python${PYVER}"
+ else
+ PYConf="$myconf --disable-pyecasound"
+ fi
+
+ econf $(use_enable alsa) \
+ $(use_enable arts) \
+ $(use_enable audiofile) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate) \
+ $(use_enable ncurses) \
+ $(use_enable oss) \
+ $(use_enable ruby rubyecasound) \
+ $(use_enable sndfile) \
+ --enable-shared \
+ --with-largefile \
+ --enable-sys-readline \
+ ${PYConf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc BUGS NEWS README TODO Documentation/*.txt
+ use doc && dohtml Documentation/*.html
+}
+
+pkg_postinst() {
+ if use python; then
+ ebegin "Byte-compiling ${CATEGORY}/${PF} python modules"
+ python_version
+ local PYMODULE
+ for PYMODULE in ecacontrol.py pyeca.py eci.py; do
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/${PYMODULE}
+ done
+ eend $?
+ fi
+ if use arts; then
+ ewarn "WARNING: You have requested ecasound ARTS support,"
+ ewarn "this is no longer supported and will go away in"
+ ewarn "future releases."
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index a210f2334dbe..0a49c5a89650 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.42 2008/08/17 08:06:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.43 2008/09/29 05:58:47 flameeyes Exp $
+
+*fluidsynth-1.0.8-r1 (29 Sep 2008)
+
+ 29 Sep 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +fluidsynth-1.0.8-r1.ebuild:
+ Add a new revision using EAPI=2 and USE dependencies.
17 Aug 2008; Alexis Ballier <aballier@gentoo.org>
-fluidsynth-1.0.7a.ebuild:
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..5546ae435fac
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.8-r1.ebuild,v 1.1 2008/09/29 05:58:47 flameeyes Exp $
+
+EAPI=2
+
+inherit flag-o-matic eutils libtool
+
+IUSE="alsa debug jack ladspa lash oss readline"
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ alsa? ( media-libs/alsa-lib[midi]
+ lash? ( >=media-sound/lash-0.5 ) )
+ readline? ( sys-libs/readline )"
+
+S="${WORKDIR}/${P/7a/7}"
+
+# Alsa is required for lash support in this package.
+pkg_setup() {
+ if use lash && ! use alsa; then
+ ewarn "ALSA support is required for lash support to be enabled."
+ ewarn "Continuing with lash support disabled."
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use alsa; then
+ myconf="${myconf} $(use_enable lash)"
+ else
+ myconf="--disable-lash"
+ fi
+
+ elibtoolize
+ # ladcca support is deprecated in place of lash
+ econf \
+ --disable-ladcca \
+ --disable-dependency-tracking \
+ $(use_enable ladspa) \
+ $(use_enable jack jack-support) \
+ $(use_enable oss oss-support) \
+ $(use_enable alsa alsa-support) \
+ $(use_enable lash) \
+ $(use_enable debug) \
+ $(use_with readline) \
+ ${myconf} || die "./configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README THANKS TODO
+}