summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-09-10 07:55:07 +0000
committerChristoph Mende <angelos@gentoo.org>2010-09-10 07:55:07 +0000
commit41a35cf451a5afaefd8af85ffe712b16a8529c0e (patch)
tree1f125281beb94240cf55bedb9b25ef0a26372499 /media-sound
parentVersion bump (bug #333407) (diff)
downloadhistorical-41a35cf451a5afaefd8af85ffe712b16a8529c0e.tar.gz
historical-41a35cf451a5afaefd8af85ffe712b16a8529c0e.tar.bz2
historical-41a35cf451a5afaefd8af85ffe712b16a8529c0e.zip
Tweak default pid/log paths (bug #331723), fix init script dependencies (bug #331725), reduce init script noise (bug #331727) and convert init script to s-s-d (bug #331729)
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpd/ChangeLog10
-rw-r--r--media-sound/mpd/files/mpd.conf.patch69
-rw-r--r--media-sound/mpd/files/mpd.init32
-rw-r--r--media-sound/mpd/mpd-0.15.12-r1.ebuild145
4 files changed, 255 insertions, 1 deletions
diff --git a/media-sound/mpd/ChangeLog b/media-sound/mpd/ChangeLog
index bc6b68adaead..834a884d2b4c 100644
--- a/media-sound/mpd/ChangeLog
+++ b/media-sound/mpd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/mpd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.207 2010/08/26 19:30:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.208 2010/09/10 07:55:07 angelos Exp $
+
+*mpd-0.15.12-r1 (06 Sep 2010)
+
+ 06 Sep 2010; <angelos@gentoo.org> +mpd-0.15.12-r1.ebuild,
+ +files/mpd.conf.patch, +files/mpd.init:
+ Tweak default pid/log paths (bug #331723), fix init script dependencies
+ (bug #331725), reduce init script noise (bug #331727) and convert init
+ script to s-s-d (bug #331729)
26 Aug 2010; Jeroen Roovers <jer@gentoo.org> mpd-0.15.12.ebuild:
Marked ~hppa (bug #333941).
diff --git a/media-sound/mpd/files/mpd.conf.patch b/media-sound/mpd/files/mpd.conf.patch
new file mode 100644
index 000000000000..d61d1218b90a
--- /dev/null
+++ b/media-sound/mpd/files/mpd.conf.patch
@@ -0,0 +1,69 @@
+diff --git a/doc/mpdconf.example b/doc/mpdconf.example
+index 11b14bd..6b24322 100644
+--- a/doc/mpdconf.example
++++ b/doc/mpdconf.example
+@@ -10,14 +10,14 @@
+ # be disabled and audio files will only be accepted over ipc socket (using
+ # file:// protocol) or streaming files over an accepted protocol.
+ #
+-#music_directory "~/music"
++music_directory "/var/lib/mpd/music"
+ #
+ # This setting sets the MPD internal playlist directory. The purpose of this
+ # directory is storage for playlists created by MPD. The server will use
+ # playlist files not created by the server but only if they are in the MPD
+ # format. This setting defaults to playlist saving being disabled.
+ #
+-#playlist_directory "~/.mpd/playlists"
++playlist_directory "/var/lib/mpd/playlists"
+ #
+ # This setting sets the location of the MPD database. This file is used to
+ # load the database at server start up and store the database while the
+@@ -25,7 +25,7 @@
+ # MPD to accept files over ipc socket (using file:// protocol) or streaming
+ # files over an accepted protocol.
+ #
+-#db_file "~/.mpd/database"
++db_file "/var/lib/mpd/database"
+ #
+ # These settings are the locations for the daemon log files for the daemon.
+ # These logs are great for troubleshooting, depending on your log_level
+@@ -34,7 +34,7 @@
+ # The special value "syslog" makes MPD use the local syslog daemon. This
+ # setting defaults to logging to syslog, otherwise logging is disabled.
+ #
+-#log_file "~/.mpd/log"
++log_file "/var/log/mpd.log"
+ #
+ # This setting sets the location of the file which stores the process ID
+ # for use of mpd --kill and some init scripts. This setting is disabled by
+@@ -47,7 +47,7 @@
+ # it was brought down. This setting is disabled by default and the server
+ # state will be reset on server start up.
+ #
+-#state_file "~/.mpd/state"
++state_file "/var/lib/mpd/state"
+ #
+ ###############################################################################
+
+@@ -59,17 +59,17 @@
+ # initialization. This setting is disabled by default and MPD is run as the
+ # current user.
+ #
+-#user "nobody"
++user "mpd"
+ #
+ # This setting sets the address for the daemon to listen on. Careful attention
+ # should be paid if this is assigned to anything other then the default, any.
+ # This setting can deny access to control of the daemon.
+ #
+ # For network
+-#bind_to_address "any"
++bind_to_address "localhost"
+ #
+ # And for Unix Socket
+-#bind_to_address "~/.mpd/socket"
++bind_to_address "/var/lib/mpd/socket"
+ #
+ # This setting is the TCP port that is desired for the daemon to get assigned
+ # to.
diff --git a/media-sound/mpd/files/mpd.init b/media-sound/mpd/files/mpd.init
new file mode 100644
index 000000000000..2a75f7d14d2c
--- /dev/null
+++ b/media-sound/mpd/files/mpd.init
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/files/mpd.init,v 1.1 2010/09/10 07:55:07 angelos Exp $
+
+depend() {
+ need localmount
+ use net netmount nfsmount alsa esound pulseaudio
+}
+
+checkconfig() {
+ if ! [ -f /etc/mpd.conf ]; then
+ eerror "Configuration file /etc/mpd.conf does not exist."
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Music Player Daemon"
+ start-stop-daemon --start --quiet --background --exec /usr/bin/mpd --pidfile /var/run/mpd.pid --make-pidfile -- --no-daemon /etc/mpd.conf 2>/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Music Player Daemon"
+ start-stop-daemon --stop --exec /usr/bin/mpd --pidfile /var/run/mpd.pid
+ eend $?
+}
diff --git a/media-sound/mpd/mpd-0.15.12-r1.ebuild b/media-sound/mpd/mpd-0.15.12-r1.ebuild
new file mode 100644
index 000000000000..4dbcc3978d65
--- /dev/null
+++ b/media-sound/mpd/mpd-0.15.12-r1.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.15.12-r1.ebuild,v 1.1 2010/09/10 07:55:07 angelos Exp $
+
+EAPI=2
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="The Music Player Daemon (mpd)"
+HOMEPAGE="http://www.musicpd.org"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~x86-fbsd"
+IUSE="aac +alsa ao audiofile avahi bzip2 cdio cue +curl debug +fifo +ffmpeg flac
+fluidsynth profile +id3 ipv6 jack lame lastfmradio libmms libsamplerate +mad
+mikmod modplug musepack +network ogg oss pipe pulseaudio sid sqlite unicode
+vorbis wavpack wildmidi zip"
+
+RDEPEND="!sys-cluster/mpich2
+ >=dev-libs/glib-2.6:2
+ aac? ( >=media-libs/faad2-2 )
+ alsa? ( media-sound/alsa-utils )
+ ao? ( >=media-libs/libao-0.8.4[alsa?,pulseaudio?] )
+ audiofile? ( media-libs/audiofile )
+ bzip2? ( app-arch/bzip2 )
+ cdio? ( dev-libs/libcdio )
+ cue? ( >=media-libs/libcue-0.13 )
+ curl? ( net-misc/curl )
+ ffmpeg? ( media-video/ffmpeg )
+ flac? ( media-libs/flac[ogg?] )
+ fluidsynth? ( media-sound/fluidsynth )
+ network? ( >=media-libs/libshout-2
+ !lame? ( !vorbis? ( media-libs/libvorbis ) ) )
+ id3? ( media-libs/libid3tag )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lame? ( network? ( media-sound/lame ) )
+ libmms? ( >=media-libs/libmms-0.4 )
+ libsamplerate? ( media-libs/libsamplerate )
+ mad? ( media-libs/libmad )
+ mikmod? ( media-libs/libmikmod )
+ modplug? ( media-libs/libmodplug )
+ musepack? ( >=media-sound/musepack-tools-444 )
+ ogg? ( media-libs/libogg )
+ pulseaudio? ( media-sound/pulseaudio )
+ sid? ( >=media-libs/libsidplay-2.1.1-r2:2 )
+ sqlite? ( dev-db/sqlite:3 )
+ vorbis? ( media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )
+ wildmidi? ( media-sound/wildmidi )
+ avahi? ( net-dns/avahi )
+ zip? ( dev-libs/zziplib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ use network || ewarn "Icecast and Shoutcast streaming needs networking."
+ use fluidsynth && ewarn "Using fluidsynth is discouraged by upstream."
+
+ enewuser mpd "" "" "/var/lib/mpd" audio
+}
+
+src_prepare() {
+ cp -f doc/mpdconf.example doc/mpdconf.dist || die "cp failed"
+ epatch "${FILESDIR}"/mpd.conf.patch
+}
+
+src_configure() {
+ local mpdconf="--disable-dependency-tracking --enable-tcp --enable-un
+ --disable-wildmidi --disable-libOggFLACtest --disable-documentation
+ --docdir=${EPREFIX}/usr/share/doc/${PF}"
+
+ if use network; then
+ mpdconf+=" --enable-shout $(use_enable vorbis vorbis-encoder)
+ --enable-httpd-output $(use_enable lame lame-encoder)"
+ if ! use lame && ! use vorbis; then
+ ewarn "At least one encoder is required, enabling vorbis for you."
+ mpdconf+=" --enable-vorbis-encoder"
+ fi
+ else
+ mpdconf+=" --disable-shout --disable-vorbis-encoder
+ --disable-httpd-output --disable-lame-encoder"
+ fi
+
+ if use flac && use ogg; then
+ mpdconf+=" --enable-oggflac"
+ else
+ mpdconf+=" --disable-oggflac"
+ fi
+
+ append-lfs-flags
+ append-ldflags "-L/usr/$(get_libdir)/sidplay/builders"
+
+ cd "${S}"
+
+ econf \
+ $(use_enable ipv6) $(use_enable cue) \
+ $(use_enable sqlite) $(use_enable curl) \
+ $(use_enable lastfmradio lastfm) $(use_enable libmms mms) \
+ $(use_enable bzip2) $(use_enable zip) \
+ $(use_enable cdio iso9660) $(use_enable id3) \
+ $(use_enable audiofile) $(use_enable ffmpeg) \
+ $(use_enable flac) $(use_enable mad) \
+ $(use_enable mikmod) $(use_enable modplug) \
+ $(use_enable musepack mpc) $(use_enable vorbis) \
+ $(use_enable sid sidplay) $(use_enable fluidsynth) \
+ $(use_enable wavpack) $(use_enable libsamplerate lsr) \
+ $(use_enable alsa) $(use_enable ao) \
+ $(use_enable fifo) $(use_enable pipe pipe-output) \
+ $(use_enable jack) $(use_enable oss) \
+ $(use_enable pulseaudio pulse) $(use_enable aac) \
+ $(use_enable debug) $(use_enable profile gprof) \
+ $(use_with avahi zeroconf avahi) $(use_enable wildmidi) \
+ ${mpdconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto /etc
+ newins doc/mpdconf.example mpd.conf
+
+ newinitd "${FILESDIR}"/mpd-r1.rc mpd
+
+ if use unicode; then
+ dosed 's:^#filesystem_charset.*$:filesystem_charset "UTF-8":' \
+ /etc/mpd.conf || die "dosed failed"
+ fi
+
+ diropts -m0755 -o mpd -g audio
+ dodir /var/lib/mpd
+ keepdir /var/lib/mpd
+ dodir /var/lib/mpd/music
+ keepdir /var/lib/mpd/music
+ dodir /var/lib/mpd/playlists
+ keepdir /var/lib/mpd/playlists
+}
+
+pkg_postinst() {
+ elog "If you will be starting mpd via /etc/init.d/mpd, please make"
+ elog "sure that MPD's pid_file is unset."
+
+ # also change the homedir if the user has existed before
+ usermod -d "/var/lib/mpd" mpd
+}