summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2006-10-15 02:35:36 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2006-10-15 02:35:36 +0000
commit4760c2955240f5c28e8e44019661dc31fd6d4c40 (patch)
tree36c8c6876ece8990bcb5f39a252d4f20752117f4 /media-sound
parentfixed listen script #151379 (diff)
downloadhistorical-4760c2955240f5c28e8e44019661dc31fd6d4c40.tar.gz
historical-4760c2955240f5c28e8e44019661dc31fd6d4c40.tar.bz2
historical-4760c2955240f5c28e8e44019661dc31fd6d4c40.zip
fixed run script
Package-Manager: portage-2.1.1
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/listen/ChangeLog8
-rw-r--r--media-sound/listen/files/digest-listen-0.5_beta1-r13
-rw-r--r--media-sound/listen/listen-0.5_beta1-r1.ebuild102
3 files changed, 110 insertions, 3 deletions
diff --git a/media-sound/listen/ChangeLog b/media-sound/listen/ChangeLog
index 5d90f7146ec1..80d7097a2848 100644
--- a/media-sound/listen/ChangeLog
+++ b/media-sound/listen/ChangeLog
@@ -1,14 +1,16 @@
# ChangeLog for media-sound/listen
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/ChangeLog,v 1.11 2006/10/15 02:32:10 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/ChangeLog,v 1.12 2006/10/15 02:35:36 bass Exp $
-*listen-0.5_beta1 (12 Oct 2006)
+*listen-0.5_beta1-r1 (15 Oct 2006)
15 Oct 2006; J. Alberto Suárez López <bass@gentoo.org>
- files/Makefile.patch, listen-0.5_beta1.ebuild:
+ files/Makefile.patch, listen-0.5_beta1-r1.ebuild:
Fixed listen script #151379
Ready for Sexy and muscibrainz but not working yet.
+*listen-0.5_beta1 (12 Oct 2006)
+
13 Oct 2006; Simon Stelling <blubb@gentoo.org> listen-0.5_beta1.ebuild:
fix wrt multilib-strict and re-add ~amd64; bug 146613
diff --git a/media-sound/listen/files/digest-listen-0.5_beta1-r1 b/media-sound/listen/files/digest-listen-0.5_beta1-r1
new file mode 100644
index 000000000000..53064cadc2a6
--- /dev/null
+++ b/media-sound/listen/files/digest-listen-0.5_beta1-r1
@@ -0,0 +1,3 @@
+MD5 9dd7b4252ccdddc44199ac0820ac4b91 listen-0.5b1.tar.gz 399479
+RMD160 a9fe8b5d81d6fe51419e15b6914df339e454a11f listen-0.5b1.tar.gz 399479
+SHA256 919a639d6b5860a135091f5d5a1d3d871f219c06e694be994a6e1213c871d028 listen-0.5b1.tar.gz 399479
diff --git a/media-sound/listen/listen-0.5_beta1-r1.ebuild b/media-sound/listen/listen-0.5_beta1-r1.ebuild
new file mode 100644
index 000000000000..043693d674f1
--- /dev/null
+++ b/media-sound/listen/listen-0.5_beta1-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/listen-0.5_beta1-r1.ebuild,v 1.1 2006/10/15 02:35:36 bass Exp $
+
+inherit eutils virtualx
+
+DESCRIPTION="A Music player and management for GNOME"
+HOMEPAGE="http://listengnome.free.fr"
+SRC_URI="mirror://sourceforge/listengnome/${PN}-0.5b1.tar.gz"
+S="${WORKDIR}/${PN}-0.5b1"
+LICENSE="GPL-2"
+IUSE="aac cdr flac ipod mad vorbis"
+#IUSE="aac cdr flac ipod mad vorbis musicbrainz libsexy"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.0
+ >=media-libs/gst-plugins-good-0.10.0
+ >=media-plugins/gst-plugins-gnomevfs-0.10.0
+ >=media-plugins/gst-plugins-gconf-0.10.0
+ >=media-plugins/gst-plugins-cdparanoia-0.10.0
+ >=media-plugins/gst-plugins-xvideo-0.10.0
+ >=media-libs/mutagen-1.6
+ >=dev-python/elementtree-1.2.6
+ mad? ( >=media-plugins/gst-plugins-mad-0.10.0
+ dev-python/pymad )
+ vorbis? ( >=media-plugins/gst-plugins-ogg-0.10.0
+ >=media-plugins/gst-plugins-vorbis-0.10.0
+ dev-python/pyvorbis
+ dev-python/pyogg )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10.0 )
+ aac? ( >=media-plugins/gst-plugins-faad-0.10.0
+ dev-python/ctypes )
+ ipod? ( >=media-libs/libgpod-0.3.2-r1 )
+ cdr? ( app-cdr/serpentine )"
+# musicbrainz? ( dev-python/python-musicbrainz
+# media-libs/tunepimp )
+
+DEPEND="${RDEPEND}
+ >=x11-libs/gtk+-2.8
+ >=media-libs/gstreamer-0.10.0
+ >=sys-apps/dbus-0.50
+ >=dev-lang/python-2.4
+ >=dev-python/pygtk-2.6
+ >=dev-python/gst-python-0.10
+ >=dev-db/sqlite-3.2.7-r1
+ >=dev-python/pysqlite-2.3.0
+ >=media-libs/mutagen-1.6
+ dev-python/gnome-python
+ dev-python/gnome-python-extras"
+# libsexy? ( dev-python/sexy-python )
+
+pkg_setup() {
+ if use ipod && ! built_with_use media-libs/libgpod python ; then
+ echo
+ eerror "In order to install iPod suport, you need to have media-libs/libgpod"
+ eerror "with 'python' in your USE flags. Please add that flag,"
+ eerror "re-emerge libgpod, and then emerge listen."
+ die "media-libs/libgpod is missing the python binding."
+ fi
+
+ if ! built_with_use sys-apps/dbus python ; then
+ echo
+ eerror "In order to install Listen, you need to have sys-apps/dbus"
+ eerror "with 'python' in your USE flags. Please add that flag,"
+ eerror "re-emerge dbus, and then emerge listen."
+ die "sys-apps/dbus is missing the python binding."
+ fi
+
+ if ! built_with_use gnome-base/gnome-vfs hal ; then
+ echo
+ eerror "In order to install Listen, you need to have gnome-base/gnome-vfs"
+ eerror "with 'hal' in your USE flags. Please add that flag,"
+ eerror "re-emerge gnome-vfs, and then emerge listen."
+ die "gnome-base/gnome-vfs is missing the hal binding."
+ fi
+}
+
+src_compile() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ addpredict /var/lib/cache/gstreamer-0.10
+ epatch "${FILESDIR}/check.patch"
+ epatch "${FILESDIR}/Makefile.patch"
+ sed -i "s:\$(PREFIX)/lib:\$(PREFIX)/$(get_libdir):g" Makefile
+ Xemake -j1 || die "make failed"
+}
+
+src_install() {
+ Xmake DESTDIR="${D}" PREFIX="/usr" install || die "Install failure"
+}
+
+pkg_postinst() {
+ echo "#!/bin/sh" > /usr/bin/listen
+ GTKMOZEMBED_PATH=$( pkg-config --libs-only-L mozilla-gtkmozembed 2>/dev/null || pkg-config --libs-only-L firefox-gtkmozembed 2>/dev/null | sed -e "s/-L//g" -e "s/[ ]/\,/" -e "s/[ ]//g" )
+ echo "LD_LIBRARY_PATH=\"${GTKMOZEMBED_PATH}\"" "/usr/lib/listen/listen.py \"\$@\"" >> /usr/bin/listen
+
+}
+