summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-01-10 13:00:16 +0000
committerSteve Dibb <beandog@gentoo.org>2009-01-10 13:00:16 +0000
commitad7589340f67e7e5ba75f9e487fd1791479a48c6 (patch)
tree7bbccaf95170e5801c6e0c8eb6ebacc6ce2eb172 /media-tv/ivtvplayer
parentInitial commit, bug 250687 (diff)
downloadhistorical-ad7589340f67e7e5ba75f9e487fd1791479a48c6.tar.gz
historical-ad7589340f67e7e5ba75f9e487fd1791479a48c6.tar.bz2
historical-ad7589340f67e7e5ba75f9e487fd1791479a48c6.zip
Add X-Osd support, bug 214296
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.28-gentoo x86_64
Diffstat (limited to 'media-tv/ivtvplayer')
-rw-r--r--media-tv/ivtvplayer/ChangeLog9
-rw-r--r--media-tv/ivtvplayer/Manifest3
-rw-r--r--media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild41
3 files changed, 50 insertions, 3 deletions
diff --git a/media-tv/ivtvplayer/ChangeLog b/media-tv/ivtvplayer/ChangeLog
index 6318361f19a8..d70b9c34b428 100644
--- a/media-tv/ivtvplayer/ChangeLog
+++ b/media-tv/ivtvplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/ivtvplayer
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtvplayer/ChangeLog,v 1.1 2008/12/12 04:44:22 beandog Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtvplayer/ChangeLog,v 1.2 2009/01/10 13:00:16 beandog Exp $
+
+*ivtvplayer-0.1.3-r1 (10 Jan 2009)
+
+ 10 Jan 2009; Steve Dibb <beandog@gentoo.org> +ivtvplayer-0.1.3-r1.ebuild:
+ Add X-Osd support, bug 214296
*ivtvplayer-0.1.3 (12 Dec 2008)
diff --git a/media-tv/ivtvplayer/Manifest b/media-tv/ivtvplayer/Manifest
index d1a9800dd79a..95a47fea6077 100644
--- a/media-tv/ivtvplayer/Manifest
+++ b/media-tv/ivtvplayer/Manifest
@@ -1,4 +1,5 @@
DIST ivtvplayer-0.1.3.tar.gz 24159 RMD160 4656db21f7d23f39508df8fb87b59ede0652beb2 SHA1 4b95a708c7815a8e115e2590c7d273810322f7db SHA256 4727057b97a5e527e9617cd14e6ee9d892532fbb5e455d70166af07c1724aa17
+EBUILD ivtvplayer-0.1.3-r1.ebuild 1054 RMD160 69e59238157e5d352ebf868666cd09736d56fec8 SHA1 50e5ebaf1b3b38df2a170d133a51689fbc707db7 SHA256 ec20e9a7c2a92a64ac94147b9d1e0381c77e3950fc3e0c5de3a9d61983784133
EBUILD ivtvplayer-0.1.3.ebuild 1019 RMD160 e42d1b7311ad4093f5d090ee01251de9cadc1301 SHA1 99d8e7b9ef40e0361867c2fced40ef17c2220531 SHA256 d875542b929ce5d8cc8cb7ce005bef4ae01602d14d7921c5c3457a07d2a4aeb0
-MISC ChangeLog 396 RMD160 39bbd94b89dced45c66f3f646da0aed19c32709e SHA1 a9f327fa11e2f78051ba544452667053647a5775 SHA256 9ccaf1fbf7ca12c9eace40786e53882734135c96d589f741223a04f6c387bbe9
+MISC ChangeLog 541 RMD160 695053300956ede4bc5c53c09c8ac53e5c0d4d1a SHA1 4a25f1f3677d7c123054f266af8fe1fdae52a969 SHA256 47247948461e26e66d2202d3df5d293a5a31a602035273e6cabf216a89c4e92c
MISC metadata.xml 161 RMD160 fee76f69ba822cd04301c58fa0c26ecaf8cc8fb9 SHA1 0aee2176f15a238a6d8fbbf83e4e0fd58653a3fa SHA256 82d33b3ca60662bc745d30d53bb20d04ea588d5aae556ed16efcacdcc37fd4bd
diff --git a/media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild b/media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..0f88b97d298c
--- /dev/null
+++ b/media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtvplayer/ivtvplayer-0.1.3-r1.ebuild,v 1.1 2009/01/10 13:00:16 beandog Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Simple IVTV command line TV and radio player with support of LIRC."
+HOMEPAGE="http://sourceforge.net/projects/ivtvplayer/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE="gtk xosd"
+RDEPEND="|| ( media-tv/ivtv media-tv/ivtv-utils )
+ || ( media-video/mplayer[v4l2]
+ media-video/mplayer[dvb] )
+ media-sound/alsa-utils
+ dev-perl/XML-Simple
+ gtk? ( dev-perl/gtk2-perl )
+ xosd? ( dev-perl/X-Osd )
+ >=dev-perl/Lirc-Client-1.50"
+DEPEND=""
+
+src_install() {
+ dobin bin/itv
+ dobin bin/iradio
+ if use gtk ; then
+ dobin bin/ictl
+ fi
+ dodoc doc/README doc/CHANGES
+ dodoc conf/*
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Example of itv, iradio and its LIRC configuration file is located in"
+ einfo "directory /usr/share/doc/${PF}/."
+ einfo ""
+}