summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-11-09 21:06:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-11-09 21:06:11 +0000
commitf5c63b6545b52b121c916870067ab71303aedba7 (patch)
treefa0ed30b87bd9340088f4b655fa7923ef7813448 /media-video/2mandvd
parentunused middle version (diff)
downloadhistorical-f5c63b6545b52b121c916870067ab71303aedba7.tar.gz
historical-f5c63b6545b52b121c916870067ab71303aedba7.tar.bz2
historical-f5c63b6545b52b121c916870067ab71303aedba7.zip
Initial commit of 2mandvd application. Fixes bug 266949
Package-Manager: portage-2.2_rc49/cvs/Linux x86_64
Diffstat (limited to 'media-video/2mandvd')
-rw-r--r--media-video/2mandvd/2mandvd-1.1.1.ebuild73
-rw-r--r--media-video/2mandvd/ChangeLog9
-rw-r--r--media-video/2mandvd/Manifest4
-rw-r--r--media-video/2mandvd/metadata.xml12
4 files changed, 98 insertions, 0 deletions
diff --git a/media-video/2mandvd/2mandvd-1.1.1.ebuild b/media-video/2mandvd/2mandvd-1.1.1.ebuild
new file mode 100644
index 000000000000..2bd9a7166407
--- /dev/null
+++ b/media-video/2mandvd/2mandvd-1.1.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.1.1.ebuild,v 1.1 2009/11/09 21:06:11 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4
+
+MY_PN="2ManDVD"
+
+DESCRIPTION="The successor of ManDVD"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="media-video/dvdauthor
+ media-video/ffmpegthumbnailer
+ media-fonts/dejavu
+ media-sound/sox
+ media-video/mplayer
+ media-libs/netpbm
+ media-video/mjpegtools
+ || ( app-cdr/cdrkit app-cdr/cdrtools )
+ media-libs/xine-lib
+ x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+LANGS="de en he it pl pt ru"
+
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+src_prepare() {
+ # fix installation path
+ for file in mainfrm.cpp media_browser.cpp rendering.cpp; do
+ sed -i "s:qApp->applicationDirPath().\?+.\?\":\"/usr/share/${PN}/:" \
+ ${file} || die "sed failed"
+ done
+
+ sed -i "s:qApp->applicationDirPath():\"/usr/share/${PN}/\":" \
+ mainfrm.cpp || die "sed failed"
+
+ qt4_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ dobin 2ManDVD || die "dobin failed"
+ dodoc README.txt || die "dodoc failed"
+ insinto /usr/share/${PN}/
+ doins -r Bibliotheque || die "failed to install Bibliotheque"
+ doins -r Interface || die "failed to install Interface"
+ doicon Interface/mandvdico.png || die "doicon failed"
+ # Desktop icon
+ make_desktop_entry 2ManDVD 2ManDVD mandvdico "Qt;AudioVideo;Video" \
+ || die "make_desktop_entry failed"
+ insinto /usr/share/${PN}
+ for lang in ${LINGUAS}; do
+ for x in ${LANGS}; do
+ [[ ${lang} == ${x} ]] && doins ${PN}_${x}.qm
+ done
+ done
+}
diff --git a/media-video/2mandvd/ChangeLog b/media-video/2mandvd/ChangeLog
new file mode 100644
index 000000000000..dbb55187d3b3
--- /dev/null
+++ b/media-video/2mandvd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-video/2mandvd
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.1 2009/11/09 21:06:11 hwoarang Exp $
+
+*2mandvd-1.1.1 (09 Nov 2009)
+
+ 09 Nov 2009; <hwoarang@gentoo.org> +2mandvd-1.1.1.ebuild, +metadata.xml:
+ Initial commit of 2mandvd application. Fixes bug 266949
+
diff --git a/media-video/2mandvd/Manifest b/media-video/2mandvd/Manifest
new file mode 100644
index 000000000000..1f591eae3f78
--- /dev/null
+++ b/media-video/2mandvd/Manifest
@@ -0,0 +1,4 @@
+DIST 2ManDVD-1.1.1.tar.gz 31756514 RMD160 5e3df26d483aa833bdb528e73a8e8cdc690393d1 SHA1 447f6b1b39a1b88a1d59634f79aeb4a2d3e00ea2 SHA256 d2761346755928f7695d4d70b7989f65ff699daf98ea884c17ccd0689e62520f
+EBUILD 2mandvd-1.1.1.ebuild 1805 RMD160 27bffb4a0f1184a63e5b6f13808616d8cde6acc7 SHA1 48e7645e7e2f3aab40384c00cb8a3eb90932447f SHA256 214807ee4e490bd09f5115d71c4fd317eb2634e609fece3e0f7a20f6c18132b8
+MISC ChangeLog 377 RMD160 eed93e4b9c983cd286c5fb0039daf37c2c26b1f3 SHA1 a3b89f2511ce53ffd320e6a3a27171cc0312a6bc SHA256 3049be748f231a0970bb55da6c1c3f6a96c0cf549857b941a7b38bc1e514d2d6
+MISC metadata.xml 294 RMD160 ac4e1baa0a1839ae0a807a9d4b915134788d6aa1 SHA1 82865de14486cb30dc9ebfe6f1aecc9c86c0075b SHA256 209af586ae032f00659b69da17d4186854660be14b244d31aa0bea2005c2c5ba
diff --git a/media-video/2mandvd/metadata.xml b/media-video/2mandvd/metadata.xml
new file mode 100644
index 000000000000..d5f9562e2df2
--- /dev/null
+++ b/media-video/2mandvd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+