summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-04-23 15:52:01 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-04-23 15:52:01 +0000
commit499464c2451254c90b474e8ec71e789ba13be39f (patch)
treed7636b4102cf169da6cb6899bc50e980dd486327 /media-video/alevt
parentTested w/ a palm pilot. Resolves bug 334 (diff)
downloadhistorical-499464c2451254c90b474e8ec71e789ba13be39f.tar.gz
historical-499464c2451254c90b474e8ec71e789ba13be39f.tar.bz2
historical-499464c2451254c90b474e8ec71e789ba13be39f.zip
intial ebuild, fixes bug #329
Diffstat (limited to 'media-video/alevt')
-rw-r--r--media-video/alevt/ChangeLog9
-rw-r--r--media-video/alevt/alevt-1.6.0.ebuild47
-rw-r--r--media-video/alevt/files/alevt-1.6.0-alevt-date.diff19
-rw-r--r--media-video/alevt/files/alevt-1.6.0-makefile.diff21
-rw-r--r--media-video/alevt/files/digest-alevt-1.6.01
5 files changed, 97 insertions, 0 deletions
diff --git a/media-video/alevt/ChangeLog b/media-video/alevt/ChangeLog
new file mode 100644
index 000000000000..995731b052d1
--- /dev/null
+++ b/media-video/alevt/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-video/alevt
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/ChangeLog,v 1.1 2002/04/23 15:52:01 verwilst Exp $
+
+*alevt-1.6.0 (23 Apr 2002)
+
+ 23 Apr 2002; Bart Verwilst <verwilst@gentoo.org> Changelog :
+
+ Initial ebuild. Nothing more to say really.. :o)
diff --git a/media-video/alevt/alevt-1.6.0.ebuild b/media-video/alevt/alevt-1.6.0.ebuild
new file mode 100644
index 000000000000..b3953854d00a
--- /dev/null
+++ b/media-video/alevt/alevt-1.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: First Last <your email>
+# $Header: /var/cvsroot/gentoo-x86/media-video/alevt/alevt-1.6.0.ebuild,v 1.1 2002/04/23 15:52:01 verwilst Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Teletext viewer for X11"
+SRC_URI="http://www.ibiblio.org/pub/Linux/apps/video/${P}.tar.gz"
+HOMEPAGE="http://"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=media-libs/libpng-1.0.12
+ >=x11-base/xfree-4.0.1"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-alevt-date.diff
+ patch -p1 < ${FILESDIR}/${PF}-makefile.diff
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ mkdir -p ${D}/usr/bin
+ mkdir -p ${D}/usr/man/man1
+ mkdir -p ${D}/usr/include/X11/pixmaps
+
+ install -m 0755 alevt ${D}/usr/bin
+ install -m 0755 alevt-date ${D}/usr/bin
+ install -m 0755 alevt-cap ${D}/usr/bin
+ install -m 0644 alevt.1x ${D}/usr/man/man1
+ install -m 0644 alevt-date.1 ${D}/usr/man/man1
+ install -m 0644 alevt-cap.1 ${D}/usr/man/man1
+ install -m 0644 contrib/mini-alevt.xpm ${D}/usr/include/X11/pixmaps
+
+ sync
+
+}
diff --git a/media-video/alevt/files/alevt-1.6.0-alevt-date.diff b/media-video/alevt/files/alevt-1.6.0-alevt-date.diff
new file mode 100644
index 000000000000..39d493443310
--- /dev/null
+++ b/media-video/alevt/files/alevt-1.6.0-alevt-date.diff
@@ -0,0 +1,19 @@
+--- alevt-1.6.0/alevt-date.c Sat Sep 16 22:34:42 2000
++++ alevt-1.6.0.ice/alevt-date.c Thu Jan 24 21:59:32 2002
+@@ -3,6 +3,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <signal.h>
++#include <time.h>
+
+ #include "os.h"
+ #include "vt.h"
+@@ -22,7 +23,7 @@
+ {
+ struct tm *tm;
+ time_t sys_t;
+- int dt;
++ int dt, timezone;
+ char buf[256];
+
+ if (t < 0 || t > 235959 || t%100 > 59 || t/100%100 > 59)
diff --git a/media-video/alevt/files/alevt-1.6.0-makefile.diff b/media-video/alevt/files/alevt-1.6.0-makefile.diff
new file mode 100644
index 000000000000..509b9136f11c
--- /dev/null
+++ b/media-video/alevt/files/alevt-1.6.0-makefile.diff
@@ -0,0 +1,21 @@
+--- alevt-1.6.0/Makefile Wed Oct 11 19:08:29 2000
++++ alevt-1.6.0.ice/Makefile Thu Jan 24 22:12:15 2002
+@@ -69,12 +69,12 @@
+ # anything below this line is just for me!
+
+ install: all
+- install -m 0755 alevt /usr/local/bin
+- install -m 0755 alevt-date /usr/local/bin
+- install -m 0755 alevt-cap /usr/local/bin
+- install -m 0644 alevt.1x /usr/local/man/man1
+- install -m 0644 alevt-date.1 /usr/local/man/man1
+- install -m 0644 alevt-cap.1 /usr/local/man/man1
++ install -m 0755 alevt /usr/bin
++ install -m 0755 alevt-date /usr/bin
++ install -m 0755 alevt-cap /usr/bin
++ install -m 0644 alevt.1x /usr/man/man1
++ install -m 0644 alevt-date.1 /usr/man/man1
++ install -m 0644 alevt-cap.1 /usr/man/man1
+ install -m 0644 contrib/mini-alevt.xpm /usr/include/X11/pixmaps
+ sync
+
diff --git a/media-video/alevt/files/digest-alevt-1.6.0 b/media-video/alevt/files/digest-alevt-1.6.0
new file mode 100644
index 000000000000..c585bc06765a
--- /dev/null
+++ b/media-video/alevt/files/digest-alevt-1.6.0
@@ -0,0 +1 @@
+MD5 3826d99d14d0a8f70f8d3625b2d06d03 alevt-1.6.0.tar.gz 116646