summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-29 22:04:39 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-29 22:04:39 +0000
commit669a93664c54cc6b09011669e294274af35d2ae1 (patch)
tree371cef6a38957893498ca6595dae3564c7c98976 /media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
parentcommit right ebuild (diff)
downloadhistorical-669a93664c54cc6b09011669e294274af35d2ae1.tar.gz
historical-669a93664c54cc6b09011669e294274af35d2ae1.tar.bz2
historical-669a93664c54cc6b09011669e294274af35d2ae1.zip
Conversion to python-single-r1 by Armageddon.
Package-Manager: portage-2.2.0_alpha190/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'media-video/subdownloader/subdownloader-2.0.18-r1.ebuild')
-rw-r--r--media-video/subdownloader/subdownloader-2.0.18-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild b/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
new file mode 100644
index 000000000000..7eab490ae433
--- /dev/null
+++ b/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subdownloader/subdownloader-2.0.18-r1.ebuild,v 1.1 2013/07/29 22:04:36 floppym Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 eutils
+
+DESCRIPTION="GUI application for automatic downloading/uploading of subtitles for videofiles"
+HOMEPAGE="http://www.subdownloader.net/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_2.0.18.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/kaa-metadata[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ python_fix_shebang "${S}"/run.py
+ insinto /usr/share/"${PN}"
+ doins -r cli FileManagement gui languages locale modules run.py
+ fperms 755 /usr/share/"${PN}"/run.py
+ dosym /usr/share/"${PN}"/run.py /usr/bin/"${PN}"
+ doman subdownloader.1
+ dodoc README ChangeLog
+ doicon gui/images/subdownloader.png
+ domenu subdownloader.desktop
+}